aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBehdad Esfahbod <behdad@behdad.org>2013-12-07 17:36:12 -0500
committerBehdad Esfahbod <behdad@behdad.org>2013-12-07 17:36:12 -0500
commit494d9d139e2a10cf96d3338b9befaffb19bec362 (patch)
tree53c7b288ab419e45525a032a4542c2df17ef73e2 /setup.py
parentc745f69d8ac5473ccfac44e08eddc84c3ea821fe (diff)
downloadfonttools-494d9d139e2a10cf96d3338b9befaffb19bec362.tar.gz
Remove eexecOp C extension
It hasn't been working: https://github.com/khaledhosny/fonttools/commit/6102ba7500171966c436aac0eb61185c26c5fcdd And it's only used to load Type1 fonts, so who cares if the Python implementation is slow...
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py10
1 files changed, 0 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 9b660881..b3ca2867 100755
--- a/setup.py
+++ b/setup.py
@@ -80,16 +80,6 @@ setup(
],
package_dir = {'': 'Lib'},
extra_path = 'FontTools',
- ext_modules = [
- Extension(
- "fontTools.misc.eexecOp",
- ["Src/eexecOp/eexecOpmodule.c"],
- include_dirs=[],
- define_macros=[],
- library_dirs=[],
- libraries=[],
- )
- ],
scripts = ["Tools/ttx", "Tools/pyftsubset", "Tools/pyftinspect"],
cmdclass = {"build_ext": build_ext_optional},
data_files = [('share/man/man1', ["Doc/ttx.1"])],