summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@google.com>2015-10-05 17:35:13 -0400
committerMike Frysinger <vapier@google.com>2015-10-05 17:35:13 -0400
commit05e355f24694bf9d45bacdc9944a7422fbbfed38 (patch)
tree7f3ce3bb86ba7e9fdb58de8b5ce366137bde8ab7
parent96c7072d8a75d4977537c075ce504156a2d91756 (diff)
downloadintegration-05e355f24694bf9d45bacdc9944a7422fbbfed38.tar.gz
portage: add make.defaults file for setting up USE
There's a bunch of settings we want to disable, so set up a make.defaults file to hold all of those in our custom profile. BUG=24611334 TEST=emerging packages no longer enables a lot of USE flags Change-Id: I0b4987e050ecf3aa20da545f7d70ed120c1b8ec4
-rw-r--r--portage/Android.mk14
-rw-r--r--portage/make.defaults.in25
2 files changed, 39 insertions, 0 deletions
diff --git a/portage/Android.mk b/portage/Android.mk
index 1c2d500..85ee609 100644
--- a/portage/Android.mk
+++ b/portage/Android.mk
@@ -87,6 +87,20 @@ $(package.provided): $(LOCAL_PATH)/package.provided.in
include $(CLEAR_VARS)
+LOCAL_MODULE := make.defaults
+LOCAL_MODULE_CLASS := ETC
+LOCAL_MODULE_PATH := $(3RD_PARTY_ROOT)/etc/portage/profile
+3RD_PARTY_CONFIGS += $(LOCAL_MODULE_PATH)/$(LOCAL_MODULE)
+
+include $(BUILD_SYSTEM)/base_rules.mk
+
+make.defaults := $(intermediates)/make.defaults
+$(make.defaults): $(LOCAL_PATH)/make.defaults.in
+ $(hide)mkdir -p $(dir $@)
+ $(hide)cp $< $@
+
+include $(CLEAR_VARS)
+
LOCAL_MODULE := gentoo.conf
LOCAL_MODULE_CLASS := ETC
LOCAL_MODULE_PATH := $(3RD_PARTY_ROOT)/etc/portage/repos.conf
diff --git a/portage/make.defaults.in b/portage/make.defaults.in
new file mode 100644
index 0000000..294f8ac
--- /dev/null
+++ b/portage/make.defaults.in
@@ -0,0 +1,25 @@
+# AUTO GENERATED. DO NOT TOUCH. DO NOT ASK OTHERS TO TOUCH.
+
+# Stub line to make the others below more consistent. Needs to come first.
+USE=""
+
+# We do not use/support PAM under Android.
+USE="${USE} -pam"
+
+# No support for translations. You'll have to handle them yourself.
+USE="${USE} -nls"
+
+# We do not allow passwords to change, so checking them is pointless.
+USE="${USE} -cracklib"
+
+# We handle firewalls/etc... differently.
+USE="${USE} -tcpd"
+
+# We do not expect command line tools to be all that interactive.
+USE="${USE} -ncurses -readline"
+
+# No support for graphics stacks.
+USE="${USE} -dri -X -gtk -qt4 -qt5"
+
+# We do not utilize udev or systemd.
+USE="${USE} -udev -systemd"