summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@google.com>2015-10-13 16:21:30 -0400
committerMike Frysinger <vapier@google.com>2015-10-13 16:21:30 -0400
commit56eeb58fd69f4505e13268146ab6043cf4ee63dd (patch)
tree00da81ff4d524ccb4be42bfb0c4ad646e3bf7b8f
parent9f2b516f9e08a5d68ee61863dd9b795b443e1f81 (diff)
downloadintegration-56eeb58fd69f4505e13268146ab6043cf4ee63dd.tar.gz
portage: add more config files
This allows us to override profile settings further: - switch from ELIBC=glibc to ELIBC=bionic - disable glib[mime] to avoid fat mime/xml deps - disable USE=static-libs by default so we only use shared libs - omit the charset.alias file from all packages as random GNU packages all want to install it (which breaks due to collisions), and the content is pretty pointless (maps like 2 obscure aliases) Change-Id: I3bfa4ba2487257e59410f54da3c5596258462b8f
-rw-r--r--portage/Android.mk42
-rw-r--r--portage/make.defaults.in9
-rw-r--r--portage/package.use.in4
-rw-r--r--portage/use.force.in5
-rw-r--r--portage/use.mask.in5
5 files changed, 65 insertions, 0 deletions
diff --git a/portage/Android.mk b/portage/Android.mk
index 3918ea1..3e0d0b7 100644
--- a/portage/Android.mk
+++ b/portage/Android.mk
@@ -100,6 +100,48 @@ $(make.defaults): $(LOCAL_PATH)/make.defaults.in
include $(CLEAR_VARS)
+LOCAL_MODULE := package.use
+LOCAL_MODULE_CLASS := ETC
+LOCAL_MODULE_PATH := $(3RD_PARTY_ROOT)/etc/portage/profile
+3RD_PARTY_CONFIGS += $(LOCAL_MODULE_PATH)/$(LOCAL_MODULE)
+
+include $(BUILD_SYSTEM)/base_rules.mk
+
+package.use := $(intermediates)/$(LOCAL_MODULE)
+$(package.use): $(LOCAL_PATH)/$(LOCAL_MODULE).in
+ $(hide)mkdir -p $(dir $@)
+ $(hide)cp $< $@
+
+include $(CLEAR_VARS)
+
+LOCAL_MODULE := use.force
+LOCAL_MODULE_CLASS := ETC
+LOCAL_MODULE_PATH := $(3RD_PARTY_ROOT)/etc/portage/profile
+3RD_PARTY_CONFIGS += $(LOCAL_MODULE_PATH)/$(LOCAL_MODULE)
+
+include $(BUILD_SYSTEM)/base_rules.mk
+
+use.force := $(intermediates)/$(LOCAL_MODULE)
+$(use.force): $(LOCAL_PATH)/$(LOCAL_MODULE).in
+ $(hide)mkdir -p $(dir $@)
+ $(hide)cp $< $@
+
+include $(CLEAR_VARS)
+
+LOCAL_MODULE := use.mask
+LOCAL_MODULE_CLASS := ETC
+LOCAL_MODULE_PATH := $(3RD_PARTY_ROOT)/etc/portage/profile
+3RD_PARTY_CONFIGS += $(LOCAL_MODULE_PATH)/$(LOCAL_MODULE)
+
+include $(BUILD_SYSTEM)/base_rules.mk
+
+use.mask := $(intermediates)/$(LOCAL_MODULE)
+$(use.mask): $(LOCAL_PATH)/$(LOCAL_MODULE).in
+ $(hide)mkdir -p $(dir $@)
+ $(hide)cp $< $@
+
+include $(CLEAR_VARS)
+
LOCAL_MODULE := gentoo.conf
LOCAL_MODULE_CLASS := ETC
LOCAL_MODULE_PATH := $(3RD_PARTY_ROOT)/etc/portage/repos.conf
diff --git a/portage/make.defaults.in b/portage/make.defaults.in
index faa53d5..7073df5 100644
--- a/portage/make.defaults.in
+++ b/portage/make.defaults.in
@@ -1,5 +1,11 @@
# AUTO GENERATED. DO NOT TOUCH. DO NOT ASK OTHERS TO TOUCH.
+# Various GNU packages try to install this file when no one should be.
+INSTALL_MASK="charset.alias"
+
+# We use Bionic for our C library.
+ELIBC="bionic"
+
# Stub line to make the others below more consistent. Needs to come first.
USE=""
@@ -26,3 +32,6 @@ USE="${USE} -dri -X -gtk -qt4 -qt5"
# We do not utilize udev or systemd.
USE="${USE} -udev -systemd"
+
+# We want shared libs everywhere!
+USE="${USE} -static-libs"
diff --git a/portage/package.use.in b/portage/package.use.in
new file mode 100644
index 0000000..5fa5a0b
--- /dev/null
+++ b/portage/package.use.in
@@ -0,0 +1,4 @@
+# AUTO GENERATED. DO NOT TOUCH. DO NOT ASK OTHERS TO TOUCH.
+
+# This requires mime data which requires libxml2 which requires glob.
+dev-libs/glib -mime
diff --git a/portage/use.force.in b/portage/use.force.in
new file mode 100644
index 0000000..b930781
--- /dev/null
+++ b/portage/use.force.in
@@ -0,0 +1,5 @@
+# AUTO GENERATED. DO NOT TOUCH. DO NOT ASK OTHERS TO TOUCH.
+
+# Make sure the right C library is active.
+-elibc_glibc
+elibc_bionic
diff --git a/portage/use.mask.in b/portage/use.mask.in
new file mode 100644
index 0000000..1e14bf8
--- /dev/null
+++ b/portage/use.mask.in
@@ -0,0 +1,5 @@
+# AUTO GENERATED. DO NOT TOUCH. DO NOT ASK OTHERS TO TOUCH.
+
+# Make sure the right C library is active.
+-elibc_bionic
+elibc_glibc