summaryrefslogtreecommitdiff
path: root/dev-dotnet/nant
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/nant
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/nant')
-rw-r--r--dev-dotnet/nant/Manifest2
-rw-r--r--dev-dotnet/nant/metadata.xml5
-rw-r--r--dev-dotnet/nant/nant-0.92.ebuild39
-rw-r--r--dev-dotnet/nant/nant-0.93_pre20130131.ebuild43
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-dotnet/nant/Manifest b/dev-dotnet/nant/Manifest
new file mode 100644
index 0000000000..1a07ac2ca1
--- /dev/null
+++ b/dev-dotnet/nant/Manifest
@@ -0,0 +1,2 @@
+DIST nant-0.92-src.tar.gz 1601180 SHA256 72d4d585267ed7f03e1aa75087d96f4f8d49ee976c32d974c5ab1fef4d4f8305 SHA512 4172b208ef22af19c456802113005652ac54b41e1baad8130eb4a9321872ee55fbc50379087aeaff7188f40d178519b35f1d74fa7e799c1fbfa046c619536005 WHIRLPOOL b5389dcf693d9e1c41297d5e59ba8caba584b819c53bb7ab8dd9810fe904c155941e0613ff9123fd2b57d1462452c9083f828cb4192d22f995f7981c0a6ac131
+DIST nant-0.93_pre20130131.tar.bz2 10828155 SHA256 c5f88105984dd6de886e7b7f61a1258806e5da5c1f2f0d6459bc5b97b817a9b7 SHA512 ab4fa73d979d6b8485ed4ad5d7938b7a7bf10030435955d0c5615ac27f0543edb823869f1773f3e9fcd1bdfe67a25a93af111daae4f8fadb7c64b65d87232e42 WHIRLPOOL d0a373d1c5b6e63919854aa2f863ca948800b873233bca1e686db0e82c8596608f35b07b8177caec7fe311378f8b68ca09bded8d1e3453f84e911ba9e573ad68
diff --git a/dev-dotnet/nant/metadata.xml b/dev-dotnet/nant/metadata.xml
new file mode 100644
index 0000000000..e01adbb307
--- /dev/null
+++ b/dev-dotnet/nant/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dotnet</herd>
+</pkgmetadata>
diff --git a/dev-dotnet/nant/nant-0.92.ebuild b/dev-dotnet/nant/nant-0.92.ebuild
new file mode 100644
index 0000000000..cc1c3ddcfd
--- /dev/null
+++ b/dev-dotnet/nant/nant-0.92.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit mono multilib eutils
+
+DESCRIPTION=".NET build tool"
+HOMEPAGE="http://nant.sourceforge.net/"
+SRC_URI="mirror://sourceforge/nant/${P/_/-}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# This build is not parallel build friendly
+MAKEOPTS="${MAKEOPTS} -j1"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_install() {
+ emake prefix="${ED}/usr" install
+
+ # Fix ${ED} showing up in the nant wrapper script, as well as silencing
+ # warnings related to the log4net library
+ sed -i \
+ -e "s:${ED}::" \
+ -e "2iexport MONO_SILENT_WARNING=1" \
+ -e "s:${ED}::" \
+ "${ED}"/usr/bin/nant || die "Sed nant failed"
+
+ dodoc README.txt
+}
diff --git a/dev-dotnet/nant/nant-0.93_pre20130131.ebuild b/dev-dotnet/nant/nant-0.93_pre20130131.ebuild
new file mode 100644
index 0000000000..eb3c390ddc
--- /dev/null
+++ b/dev-dotnet/nant/nant-0.93_pre20130131.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit mono-env eutils
+
+DESCRIPTION=".NET build tool"
+HOMEPAGE="http://nant.sourceforge.net/"
+SRC_URI="http://dev.gentoo.org/~pacho/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+# This build is not parallel build friendly
+MAKEOPTS="${MAKEOPTS} -j1"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake TARGET=mono-4.5 MCS="gmcs -sdk:4"
+}
+
+src_install() {
+ emake prefix="${ED}/usr" TARGET=mono-4.5 MCS="gmcs -sdk:4" install
+
+ # Fix ${ED} showing up in the nant wrapper script, as well as silencing
+ # warnings related to the log4net library
+ sed -i \
+ -e "s:${ED}::" \
+ -e "2iexport MONO_SILENT_WARNING=1" \
+ -e "s:${ED}::" \
+ "${ED}"/usr/bin/nant || die "Sed nant failed"
+
+ dodoc README.txt
+}