summaryrefslogtreecommitdiff
path: root/dev-java/jcalendar
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jcalendar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jcalendar')
-rw-r--r--dev-java/jcalendar/Manifest2
-rw-r--r--dev-java/jcalendar/jcalendar-1.3.3.ebuild49
-rw-r--r--dev-java/jcalendar/jcalendar-1.4.ebuild49
-rw-r--r--dev-java/jcalendar/metadata.xml16
4 files changed, 116 insertions, 0 deletions
diff --git a/dev-java/jcalendar/Manifest b/dev-java/jcalendar/Manifest
new file mode 100644
index 0000000000..3e24b34692
--- /dev/null
+++ b/dev-java/jcalendar/Manifest
@@ -0,0 +1,2 @@
+DIST jcalendar-1.3.3.zip 669499 SHA256 1dbbf9037026b32adfd123d3946c3ca272075f8b4ddf205436cddeffae320ac9 SHA512 966cb1f063b15bb941e9e263bd0dcf8a6121a6fa37ed2def69be6031856a1459a198f1b10202d697aafff8c71ad6f4e191449014bb692385c066f2c93b9c73fd WHIRLPOOL 39ef9f370b9ddc7c04717c45b34614919e65e54d52b6c2c0b0898b38d917d470e2442bfde08f2b94d567c8806749651aa00362363d38b4a13ba6fae3171a1b58
+DIST jcalendar-1.4.zip 982517 SHA256 21fb9332aad57d9542e9833376686a4bc7612e979c638e97334421bd15447c4f SHA512 aeab6f98451f4fa8718e127de6c0af345410bebbd1de4fa1ca4b9e7f5a22908f9e455ba96da34ef9e8691b4d462e8a01dbd7881b6565a0f3a65d18fe58b68d9c WHIRLPOOL 8c25a8918ef7d83cce59c347701a7af8e3a1bd307398f80d9e2d9d076afae05daaa56e1430eba167139aaae6193ed84a6c860d68ecd286992be71bec9e0dd388
diff --git a/dev-java/jcalendar/jcalendar-1.3.3.ebuild b/dev-java/jcalendar/jcalendar-1.3.3.ebuild
new file mode 100644
index 0000000000..04f8706068
--- /dev/null
+++ b/dev-java/jcalendar/jcalendar-1.3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Java date chooser bean for graphically picking a date"
+SRC_URI="http://www.toedter.com/download/${P}.zip"
+HOMEPAGE="http://www.toedter.com/en/jcalendar/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.2"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+COMMON_DEPEND="dev-java/jgoodies-looks:2.0"
+
+RDEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.4
+ >=app-arch/unzip-5.50-r1
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}"
+
+# NOTE: build.xml contains no tests
+
+java_prepare() {
+ cd lib || die
+ rm -v *.jar || die
+
+ java-pkg_jar-from jgoodies-looks-2.0
+}
+
+EANT_BUILD_XML="src/build.xml"
+EANT_DOC_TARGET="dist"
+
+src_install() {
+ java-pkg_newjar lib/${P}.jar
+
+ dodoc readme.txt
+
+ use doc && java-pkg_dohtml -r doc/*
+ use source && java-pkg_dosrc src/com
+}
diff --git a/dev-java/jcalendar/jcalendar-1.4.ebuild b/dev-java/jcalendar/jcalendar-1.4.ebuild
new file mode 100644
index 0000000000..fa558a8ee1
--- /dev/null
+++ b/dev-java/jcalendar/jcalendar-1.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java date chooser bean for graphically picking a date"
+SRC_URI="http://www.toedter.com/download/${P}.zip"
+HOMEPAGE="http://www.toedter.com/en/jcalendar/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.2"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="dev-java/jgoodies-looks:2.6"
+
+RDEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.4
+ >=app-arch/unzip-5.50-r1
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}"
+
+RESTRICT="test"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="jgoodies-looks-2.6"
+EANT_BUILD_XML="src/build.xml"
+EANT_BUILD_TARGET="jar"
+EANT_DOC_TARGET=""
+
+java_prepare() {
+ rm lib/*.jar || die
+}
+
+src_install() {
+ java-pkg_newjar lib/${P}.jar
+
+ dodoc readme.txt
+
+ use doc && java-pkg_dohtml -r doc/*
+ use source && java-pkg_dosrc src/com
+}
diff --git a/dev-java/jcalendar/metadata.xml b/dev-java/jcalendar/metadata.xml
new file mode 100644
index 0000000000..3754862a00
--- /dev/null
+++ b/dev-java/jcalendar/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+<herd>java</herd>
+
+<longdescription>
+
+JCalendar is a Java date chooser bean for graphically picking a date. JCalendar
+is composed of several other Java beans, a JDayChooser, a JMonthChooser and a
+JYearChooser. All these beans have a locale property, provide several icons
+(Color 16x16, Color 32x32, Mono 16x16 and Mono 32x32) and their own locale
+property editor. So they can easily be used in GUI builders.
+
+</longdescription>
+</pkgmetadata>