summaryrefslogtreecommitdiff
path: root/dev-lua/luasocket
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-lua/luasocket
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-lua/luasocket')
-rw-r--r--dev-lua/luasocket/Manifest2
-rw-r--r--dev-lua/luasocket/files/luasocket-2.0.2-unixsocket.patch25
-rw-r--r--dev-lua/luasocket/luasocket-2.0.2.ebuild49
-rw-r--r--dev-lua/luasocket/luasocket-3.0_rc1-r3.ebuild50
-rw-r--r--dev-lua/luasocket/metadata.xml11
5 files changed, 137 insertions, 0 deletions
diff --git a/dev-lua/luasocket/Manifest b/dev-lua/luasocket/Manifest
new file mode 100644
index 0000000000..5dfeba3d57
--- /dev/null
+++ b/dev-lua/luasocket/Manifest
@@ -0,0 +1,2 @@
+DIST luasocket-2.0.2.tar.gz 115443 SHA256 4fd9c775cfd98841299851e29b30176caf289370fea1ff1e00bb67c2d6842ca6 SHA512 3ea46dc96a4530def11c2c0ad34c9e2e9d2095b1b671ca7dd29c91953adcb22d621de3960f65045d15fd0a16b1c75c629c8cef1218281fd2d3373c76dc4759f3 WHIRLPOOL 34d68f1f7cbe2c56108d038af9f776c38917deb759398b13fc7f9b879505699a710f9a8c815e3f05a23d840777bebf84eddf8555edc5f948e26338a8f246c4c9
+DIST luasocket-3.0_rc1.tar.gz 328598 SHA256 8b67d9b5b545e1b694753dab7bd6cdbc24c290f2b21ba1e14c77b32817ea1249 SHA512 f6efce259aaacaa11472911471f8a13b118fe009b8953a82c6aa18b9ec829cd1293180904e56935cb130d36d267e3f27c91db2d78e03f7488f3e100571ed0540 WHIRLPOOL 31870d4450f0dffbf74669450188c0e491c916ec5b1df853ce8400987bc99528b730b5de9063183d9e75433af412ccacaa8c41ed9c34720f2c2f63c62c817923
diff --git a/dev-lua/luasocket/files/luasocket-2.0.2-unixsocket.patch b/dev-lua/luasocket/files/luasocket-2.0.2-unixsocket.patch
new file mode 100644
index 0000000000..15f4fe0149
--- /dev/null
+++ b/dev-lua/luasocket/files/luasocket-2.0.2-unixsocket.patch
@@ -0,0 +1,25 @@
+Index: luasocket-2.0.2/makefile
+===================================================================
+--- luasocket-2.0.2.orig/makefile
++++ luasocket-2.0.2/makefile
+@@ -45,6 +47,7 @@ install: all
+ #cd src; $(INSTALL_DATA) $(TO_MIME_SHARE) $(INSTALL_MIME_SHARE)
+ cd src; mkdir -p $(INSTALL_MIME_LIB)
+ cd src; $(INSTALL_EXEC) $(MIME_SO) $(INSTALL_MIME_LIB)/core.$(EXT)
++ cd src; $(INSTALL_EXEC) $(UNIX_SO) $(INSTALL_SOCKET_LIB)/unix.$(EXT)
+
+ #------
+ # End of makefile
+Index: luasocket-2.0.2/src/makefile
+===================================================================
+--- luasocket-2.0.2.orig/src/makefile
++++ luasocket-2.0.2/src/makefile
+@@ -47,7 +47,7 @@ UNIX_OBJS:=\
+ usocket.o \
+ unix.o
+
+-all: $(SOCKET_SO) $(MIME_SO)
++all: $(SOCKET_SO) $(MIME_SO) $(UNIX_SO)
+
+ $(SOCKET_SO): $(SOCKET_OBJS)
+ $(LD) $(LDFLAGS) -o $@ $(SOCKET_OBJS)
diff --git a/dev-lua/luasocket/luasocket-2.0.2.ebuild b/dev-lua/luasocket/luasocket-2.0.2.ebuild
new file mode 100644
index 0000000000..9d75d8c8c6
--- /dev/null
+++ b/dev-lua/luasocket/luasocket-2.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit multilib toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="Networking support library for the Lua language"
+HOMEPAGE="http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/"
+SRC_URI="http://luaforge.net/frs/download.php/2664/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/lua-5.1[deprecated]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Unix socket support is needed by app-crypt/ekeyd, but upstream
+ # does not seem to enable it by default.
+ epatch "${FILESDIR}"/${P}-unixsocket.patch
+}
+
+src_compile() {
+ # We append flags here to avoid editing the config file
+ use debug && append-flags -DLUASOCKET_DEBUG
+ append-flags -fPIC
+
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC) -shared" \
+ || die
+}
+
+src_install() {
+ emake install \
+ INSTALL_TOP_SHARE="${D}/$(pkg-config --variable INSTALL_LMOD lua)" \
+ INSTALL_TOP_LIB="${D}/$(pkg-config --variable INSTALL_CMOD lua | sed -e "s:lib/:$(get_libdir)/:")" \
+ || die
+
+ dodoc NEW README || die
+ dohtml doc/* || die
+}
diff --git a/dev-lua/luasocket/luasocket-3.0_rc1-r3.ebuild b/dev-lua/luasocket/luasocket-3.0_rc1-r3.ebuild
new file mode 100644
index 0000000000..dc6337b1e4
--- /dev/null
+++ b/dev-lua/luasocket/luasocket-3.0_rc1-r3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib multilib-minimal flag-o-matic
+
+DESCRIPTION="Networking support library for the Lua language"
+HOMEPAGE="http://www.tecgraf.puc-rio.br/~diego/professional/luasocket/"
+SRC_URI="https://github.com/diegonehab/${PN}/archive/v${PV/_/-}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ~mips ppc ppc64 sparc x86"
+IUSE="debug"
+
+RDEPEND=">=dev-lang/lua-5.1.5-r2[deprecated,${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+S=${WORKDIR}/${PN}-${PV/_/-}
+
+RESTRICT="test"
+
+src_prepare() {
+ multilib_copy_sources
+}
+
+multilib_src_compile() {
+ emake \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ LD="$(tc-getCC) ${LDFLAGS}"\
+ $(usex debug DEBUG="DEBUG" "")
+}
+
+multilib_src_install() {
+ local luav=$($(tc-getPKG_CONFIG) --variable V lua)
+ emake \
+ DESTDIR="${D}" \
+ LUAPREFIX_linux=/usr \
+ LUAV=${luav} \
+ CDIR_linux=$(get_libdir)/lua/${luav} \
+ install-unix
+}
+
+multilib_src_install_all() {
+ dodoc NEW README
+ dohtml -r doc/.
+}
diff --git a/dev-lua/luasocket/metadata.xml b/dev-lua/luasocket/metadata.xml
new file mode 100644
index 0000000000..96c70c6ec4
--- /dev/null
+++ b/dev-lua/luasocket/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">diegonehab/luasocket</remote-id>
+ </upstream>
+</pkgmetadata>