summaryrefslogtreecommitdiff
path: root/media-radio/gpredict/gpredict-1.3.ebuild
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-radio/gpredict/gpredict-1.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-radio/gpredict/gpredict-1.3.ebuild')
-rw-r--r--media-radio/gpredict/gpredict-1.3.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-radio/gpredict/gpredict-1.3.ebuild b/media-radio/gpredict/gpredict-1.3.ebuild
new file mode 100644
index 0000000000..db2e596d08
--- /dev/null
+++ b/media-radio/gpredict/gpredict-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Real-time satellite tracking and orbit prediction application"
+HOMEPAGE="http://gpredict.oz9aec.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.22.0:2
+ >=x11-libs/gtk+-2.18.0:2
+ >=x11-libs/goocanvas-0.14:0
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ # remove wrong doc location
+ epatch "${FILESDIR}/${PN}-1.1-doc.patch"
+ sed -i -e "s/0.15/0.14/g" configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ make_desktop_entry ${PN} "GPredict" "/usr/share/pixmaps/gpredict/icons/gpredict-icon.png" Science
+ # provide a link to GPL license to allow the program to show it (see
+ # Help->license menu entry)
+ dosym /usr/portage/licenses/GPL-2 /usr/share/${PN}/COPYING
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}