summaryrefslogtreecommitdiff
path: root/net-libs
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-01-19 10:48:15 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-01-19 10:48:27 +0100
commit8d2c35864d5622937da47188645bd812613abe4f (patch)
tree5f45df74c1e5ec934201d17417d2b734f80f0d9a /net-libs
parente5db9a1eff9ea918423e85fd5b559ffcacf694ca (diff)
downloadgentoo-8d2c35864d5622937da47188645bd812613abe4f.tar.gz
net-libs/nodejs: Bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/nodejs/Manifest1
-rw-r--r--net-libs/nodejs/nodejs-5.4.1.ebuild156
2 files changed, 157 insertions, 0 deletions
diff --git a/net-libs/nodejs/Manifest b/net-libs/nodejs/Manifest
index fcdfc2154e..abbfb420e0 100644
--- a/net-libs/nodejs/Manifest
+++ b/net-libs/nodejs/Manifest
@@ -4,3 +4,4 @@ DIST node-v4.1.1.tar.xz 12818088 SHA256 f7ca9ceb0b7cc49b12f28a652c908a1f0ffbf34c
DIST node-v4.2.2.tar.xz 12791572 SHA256 b016c3d2f434f86d8d3da9ad90ffb2fd35b32223e9081e3d4f67b8de0370ce69 SHA512 fe6563ca641581afa4ba7fda1b25175eae474aeb196504cd82a6486bf9dfe6c753c554b31d9aa3b6453c509aa792615e897343de69a0b8bfd26759efaea2e1cb WHIRLPOOL 2c2927697370c17cc3178e8dfbfe5819f5a406f84b28da4813507033b14d20616fe610e161618a6aea1463ac499c2d5a559360b97f236005db60ae9879ea8167
DIST node-v5.0.0.tar.xz 12863764 SHA256 cf4f261618e19517c8cbf2fdde00d0b5160e271760abee00f387b11a0b3ca834 SHA512 5b07af6b77a25924e3028257a511f035df943b854c694168e24c20f6aa735cde72546fc231d63a491367e16232ee9b6622d1f748624bf3e99e0d0468528e96c3 WHIRLPOOL 8958da059e0bc8e196d9b5f1b079f6d1927a3707b466fdc6e87ece676f981a7f22c4fa485bdb6de9879305cf2deb578d49840dee6d69d1cddba698e070b19923
DIST node-v5.3.0.tar.xz 12776504 SHA256 e5115ee78c31ac3af0f2b3553aa84fff2f49ae59bd6e01e11d78ce86c544569e SHA512 f65773c35ce774bc6fe242f8627e5786f441f0286f7d272e854e2e2d6b927d5f368c366ff52dd780f7817fedf3935ec25e78ed3f81d4613495663eb81e2afbb1 WHIRLPOOL 5f270ed6fe35dba091bd75e6ad9de419c781fc6f919915a4117b8c0bbb2ea11a05369a9149e4f69614de508ff109eb94b24bdafc0832e91e055f01b0ef214c67
+DIST node-v5.4.1.tar.xz 12812444 SHA256 4e7d3fdfeac85c46ddaef0224695620f218e7a178e97d6e210d6d643483f1d53 SHA512 9803478d502bf11bfc77e56109568b0f64186826be35a9b36b47b63ec744595db128955e6f7bec7eb4db39e85afdd364b1215427954ce33ab67689ff03a5bc57 WHIRLPOOL 87f791f4f0722a2d3bcb630d22548f395ac0e86dedc37849caab2d63bc43bad2621058f95eb2b31b1f3b01ec8585c0731c969a1f0167d95495008b44f3b69066
diff --git a/net-libs/nodejs/nodejs-5.4.1.ebuild b/net-libs/nodejs/nodejs-5.4.1.ebuild
new file mode 100644
index 0000000000..c47c0905fd
--- /dev/null
+++ b/net-libs/nodejs/nodejs-5.4.1.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit flag-o-matic pax-utils python-single-r1 toolchain-funcs
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="debug icu +npm snapshot +ssl"
+
+RDEPEND="icu? ( >=dev-libs/icu-55:= )
+ ${PYTHON_DEPS}
+ >=net-libs/http-parser-2.5:=
+ >=dev-libs/libuv-1.6.1:=
+ >=dev-libs/openssl-1.0.2d:0=[-bindist]
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ !!net-libs/iojs"
+
+S="${WORKDIR}/node-v${PV}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] ; then
+ if ! test-flag-CXX -std=c++11 ; then
+ die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
+ fi
+ fi
+}
+
+src_prepare() {
+ tc-export CC CXX PKG_CONFIG
+ export V=1 # Verbose build
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # https://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+ sed -i -e "s/|| 'python'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" lib/module.js || die
+ sed -i -e "s|\"lib\"|\"${LIBDIR}\"|" deps/npm/lib/npm.js || die
+
+ # Avoid a test that I've only been able to reproduce from emerge. It doesnt
+ # seem sandbox related either (invoking it from a sandbox works fine).
+ # The issue is that no stdin handle is openened when asked for one.
+ # It doesn't really belong upstream , so it'll just be removed until someone
+ # with more gentoo-knowledge than me (jbergstroem) figures it out.
+ rm test/parallel/test-stdout-close-unref.js || die
+ # AssertionError: 1 == 2 (on line 97)
+ rm test/parallel/test-cluster-disconnect.js || die
+ # AssertionError: Client never errored
+ rm test/parallel/test-tls-hello-parser-failure.js || die
+ # --- TIMEOUT ---
+ rm test/parallel/test-child-process-fork-net.js \
+ test/parallel/test-child-process-fork-net2.js \
+ test/parallel/test-child-process-recv-handle.js \
+ test/parallel/test-cluster-dgram-1.js \
+ test/parallel/test-cluster-send-deadlock.js \
+ test/parallel/test-cluster-shared-handle-bind-error.js \
+ test/parallel/test-dgram-exclusive-implicit-bind.js \
+ test/parallel/test-tls-ticket-cluster.js || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py || die
+ BUILDTYPE=Debug
+ fi
+
+ epatch_user
+}
+
+src_configure() {
+ local myarch=""
+ local myconf+=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
+ use npm || myconf+=( --without-npm )
+ use icu && myconf+=( --with-intl=system-icu )
+ use snapshot && myconf+=( --with-snapshot )
+ use ssl || myconf+=( --without-ssl )
+ use debug && myconf+=( --debug )
+
+ case ${ABI} in
+ x86) myarch="ia32";;
+ amd64) myarch="x64";;
+ x32) myarch="x32";;
+ arm) myarch="arm";;
+ arm64) myarch="arm64";;
+ *) die "Unrecognized ARCH ${ARCH}";;
+ esac
+
+ GYP_DEFINES="linux_use_gold_flags=0
+ linux_use_bundled_binutils=0
+ linux_use_bundled_gold=0" \
+ "${PYTHON}" configure \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ --without-dtrace \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake -C out mksnapshot
+ pax-mark m "out/${BUILDTYPE}/mksnapshot"
+ emake -C out
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ emake install DESTDIR="${ED}" PREFIX=/usr
+ if use npm; then
+ dodoc -r "${LIBDIR}"/node_modules/npm/html
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html} || die
+ find "${LIBDIR}"/node_modules -type f -name "LICENSE*" -or -name "LICENCE*" -delete || die
+ fi
+
+ # set up a symlink structure that npm expects..
+ dodir /usr/include/node/deps/{v8,uv}
+ dosym . /usr/include/node/src
+ for var in deps/{uv,v8}/include; do
+ dosym ../.. /usr/include/node/${var}
+ done
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ out/${BUILDTYPE}/cctest || die
+ declare -xl TESTTYPE="${BUILDTYPE}"
+ "${PYTHON}" tools/test.py --mode=${TESTTYPE} -J message parallel sequential || die
+}
+
+pkg_postinst() {
+ einfo "When using node-gyp to install native modules, you can avoid"
+ einfo "having to download the full tarball by doing the following:"
+ einfo ""
+ einfo "node-gyp --nodedir /usr/include/node <command>"
+}