summaryrefslogtreecommitdiff
path: root/net-mail/mailutils
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-mail/mailutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-mail/mailutils')
-rw-r--r--net-mail/mailutils/Manifest1
-rw-r--r--net-mail/mailutils/files/comsatd.initd24
-rw-r--r--net-mail/mailutils/files/imap4d.initd24
-rw-r--r--net-mail/mailutils/files/mail5
-rw-r--r--net-mail/mailutils/files/mailutils-2.99.98-array_bounds.patch11
-rw-r--r--net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch39
-rw-r--r--net-mail/mailutils/files/mailutils.rc11
-rw-r--r--net-mail/mailutils/files/pop3d.initd24
-rw-r--r--net-mail/mailutils/mailutils-2.99.98.ebuild133
-rw-r--r--net-mail/mailutils/metadata.xml10
10 files changed, 282 insertions, 0 deletions
diff --git a/net-mail/mailutils/Manifest b/net-mail/mailutils/Manifest
new file mode 100644
index 0000000000..ea64dd97e7
--- /dev/null
+++ b/net-mail/mailutils/Manifest
@@ -0,0 +1 @@
+DIST mailutils-2.99.98.tar.xz 2505252 SHA256 62e2c28aed77e451e05ed15e68b5abc3932bcc3d2d6caf9b4a6864258c6a7b1a SHA512 fc20d97b3eed0f0ff7f1d7885e59f8de6ffd5b4646cd06c3636bda4a6bc9f7a0d5acdc7bb3bb573cdc80d63dfdc0be6464033ef2f6d88514bd2190f6611a1083 WHIRLPOOL c0f6f4f9dc2d60074c06a6c8f604fa4d92df4dafd6e205df8c360e97663e96c9b64a02aab9af7eab0659abc39e8aed70bbb0761b7d5a21b5873beabbcd409030
diff --git a/net-mail/mailutils/files/comsatd.initd b/net-mail/mailutils/files/comsatd.initd
new file mode 100644
index 0000000000..db558b819e
--- /dev/null
+++ b/net-mail/mailutils/files/comsatd.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+
+#---------------------------------------------------------------------------
+# This script starts/stops the GNU Mailutils Comsatd
+#---------------------------------------------------------------------------
+
+daemon="GNU Mailutils Comsatd"
+exec="/usr/sbin/comsatd"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting $daemon"
+ start-stop-daemon --start --quiet --exec ${exec} -- -d 1>&2
+ eend $? "Error starting $daemon"
+}
+
+stop() {
+ ebegin "Stopping $daemon"
+ start-stop-daemon --stop --quiet --exec ${exec} 1>&2
+ eend $? "Error stopping $daemon"
+}
diff --git a/net-mail/mailutils/files/imap4d.initd b/net-mail/mailutils/files/imap4d.initd
new file mode 100644
index 0000000000..740530069f
--- /dev/null
+++ b/net-mail/mailutils/files/imap4d.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+
+#---------------------------------------------------------------------------
+# This script starts/stops the GNU Mailutils Imap4d
+#---------------------------------------------------------------------------
+
+daemon="GNU Mailutils Imap4d"
+exec="/usr/sbin/imap4d"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting $daemon"
+ start-stop-daemon --start --quiet --exec ${exec} -- -d 1>&2
+ eend $? "Error starting $daemon"
+}
+
+stop() {
+ ebegin "Stopping $daemon"
+ start-stop-daemon --stop --quiet --exec ${exec} 1>&2
+ eend $? "Error stopping $daemon"
+}
diff --git a/net-mail/mailutils/files/mail b/net-mail/mailutils/files/mail
new file mode 100644
index 0000000000..413ca858a6
--- /dev/null
+++ b/net-mail/mailutils/files/mail
@@ -0,0 +1,5 @@
+# Sample mail config file
+# See info mail for more options
+
+# no debug
+debug { };
diff --git a/net-mail/mailutils/files/mailutils-2.99.98-array_bounds.patch b/net-mail/mailutils/files/mailutils-2.99.98-array_bounds.patch
new file mode 100644
index 0000000000..8ac418c7c0
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-2.99.98-array_bounds.patch
@@ -0,0 +1,11 @@
+--- libmu_auth/ldap.c 2012-03-25 14:02:22.000000000 +0300
++++ libmu_auth/ldap.c 2013-03-22 12:29:19.034880845 +0200
+@@ -534,7 +534,7 @@
+
+ env[0] = "user";
+ env[1] = key;
+- env[3] = NULL;
++ env[2] = NULL;
+
+ ws.ws_env = env;
+ if (mu_wordsplit (filter_pat, &ws,
diff --git a/net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch b/net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch
new file mode 100644
index 0000000000..de9a487aaa
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils-2.99.98-readline-6.3.patch
@@ -0,0 +1,39 @@
+https://bugs.gentoo.org/503954
+
+fix build w/readline-6.3
+
+patch by Martin von Gagern
+
+--- mailutils-2.99.98/mu/shell.c
++++ mailutils-2.99.98/mu/shell.c
+@@ -336,7 +336,7 @@ mutool_initialize_readline (const char *
+ {
+ /* Allow conditional parsing of the ~/.inputrc file. */
+ rl_readline_name = (char *) name;
+- rl_attempted_completion_function = (CPPFunction *) shell_completion;
++ rl_attempted_completion_function = shell_completion;
+ rl_getc_function = _shell_getc;
+ read_history (get_history_file_name ());
+ }
+--- mailutils-2.99.98/mail/mailline.c
++++ mailutils-2.99.98/mail/mailline.c
+@@ -93,7 +93,7 @@ ml_readline_init ()
+
+ #ifdef WITH_READLINE
+ rl_readline_name = "mail";
+- rl_attempted_completion_function = (CPPFunction*)ml_command_completion;
++ rl_attempted_completion_function = ml_command_completion;
+ rl_getc_function = ml_getc;
+ #endif
+ #ifdef HAVE_SIGACTION
+--- mailutils-2.99.98/examples/nntpclient.c
++++ mailutils-2.99.98/examples/nntpclient.c
+@@ -163,7 +163,7 @@ initialize_readline ()
+ rl_readline_name = (char *) "nntp";
+
+ /* Tell the completer that we want a crack first. */
+- rl_attempted_completion_function = (CPPFunction *) nntp_completion;
++ rl_attempted_completion_function = nntp_completion;
+ }
+
+ /* Attempt to complete on the contents of TEXT. START and END bound the
diff --git a/net-mail/mailutils/files/mailutils.rc b/net-mail/mailutils/files/mailutils.rc
new file mode 100644
index 0000000000..07a551963e
--- /dev/null
+++ b/net-mail/mailutils/files/mailutils.rc
@@ -0,0 +1,11 @@
+# Sample mailutils config file. Read by all mailutils programs.
+# See info mailutils for details.
+
+# Gentoo default is maildir
+mailbox {
+ mailbox-type maildir;
+ mailbox-pattern .maildir;
+};
+
+# Place individual config files here
+include /etc/mailutils.d/;
diff --git a/net-mail/mailutils/files/pop3d.initd b/net-mail/mailutils/files/pop3d.initd
new file mode 100644
index 0000000000..1e9d5f2902
--- /dev/null
+++ b/net-mail/mailutils/files/pop3d.initd
@@ -0,0 +1,24 @@
+#!/sbin/runscript
+
+#---------------------------------------------------------------------------
+# This script starts/stops the GNU Mailutils Pop3d
+#---------------------------------------------------------------------------
+
+daemon="GNU Mailutils Pop3d"
+exec="/usr/sbin/pop3d"
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting $daemon"
+ start-stop-daemon --start --quiet --exec ${exec} -- -d 1>&2
+ eend $? "Error starting $daemon"
+}
+
+stop() {
+ ebegin "Stopping $daemon"
+ start-stop-daemon --stop --quiet --exec ${exec} 1>&2
+ eend $? "Error stopping $daemon"
+}
diff --git a/net-mail/mailutils/mailutils-2.99.98.ebuild b/net-mail/mailutils/mailutils-2.99.98.ebuild
new file mode 100644
index 0000000000..9df62c30cb
--- /dev/null
+++ b/net-mail/mailutils/mailutils-2.99.98.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_DEPEND="python? 2"
+
+inherit eutils flag-o-matic python toolchain-funcs
+
+DESCRIPTION="A useful collection of mail servers, clients, and filters"
+HOMEPAGE="http://www.gnu.org/software/mailutils/mailutils.html"
+#SRC_URI="mirror://gnu/mailutils/${P}.tar.xz"
+SRC_URI="mirror://gnu-alpha/mailutils/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~hppa ~ppc x86 ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="berkdb bidi +clients gdbm sasl guile ipv6 kerberos ldap mysql nls pam postgres
+python servers ssl static-libs +threads tcpd tokyocabinet"
+
+# Drop the libtool dep once libltdl goes stable.
+RDEPEND="!mail-client/nmh
+ !mail-filter/libsieve
+ !mail-client/mailx
+ !mail-client/nail
+ sys-libs/ncurses
+ sys-libs/readline
+ || ( dev-libs/libltdl:0 <sys-devel/libtool-2.4.3-r2:2 )
+ virtual/mta
+ berkdb? ( sys-libs/db )
+ bidi? ( dev-libs/fribidi )
+ gdbm? ( sys-libs/gdbm )
+ guile? ( dev-scheme/guile )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap )
+ mysql? ( virtual/mysql )
+ nls? ( sys-devel/gettext )
+ pam? ( virtual/pam )
+ postgres? ( dev-db/postgresql )
+ sasl? ( virtual/gsasl )
+ ssl? ( net-libs/gnutls )
+ tcpd? ( sys-apps/tcp-wrappers )
+ tokyocabinet? ( dev-db/tokyocabinet )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ # Disable bytecompilation of Python modules.
+ echo "#!/bin/sh" > build-aux/py-compile
+ epatch "${FILESDIR}/${P}-array_bounds.patch"
+ epatch "${FILESDIR}/${P}-readline-6.3.patch" #503954
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+
+ # maildir is the Gentoo default
+ # but fails tests. So set it in config file instead.
+ #econf MU_DEFAULT_SCHEME=maildir \
+ econf CURSES_LIBS="$($(tc-getPKG_CONFIG) --libs ncurses)" \
+ $(use_with berkdb berkeley-db) \
+ $(use_with bidi fribidi) \
+ $(use_enable ipv6) \
+ $(use_with gdbm) \
+ $(use_with sasl gsasl) \
+ $(use_with guile) \
+ $(use_with kerberos gssapi) \
+ $(use_with ldap) \
+ $(use_with mysql) \
+ $(use_enable nls) \
+ $(use_enable pam) \
+ $(use_with postgres) \
+ $(use_enable python) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static) \
+ $(use_enable threads pthread) \
+ $(use_with tokyocabinet) \
+ $(use_enable servers build-servers) \
+ $(use_enable clients build-clients) \
+ --with-mail-spool=/var/spool/mail \
+ --with-readline \
+ --enable-sendmail \
+ --disable-debug \
+ --disable-rpath
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc
+ doins "${FILESDIR}/mailutils.rc"
+ keepdir /etc/mailutils.d/
+ insinto /etc/mailutils.d
+ doins "${FILESDIR}/mail"
+
+ if use python; then
+ python_clean_installation_image
+ rm -f "${ED}$(python_get_sitedir)/mailutils/c_api.a"
+ fi
+
+ if use servers; then
+ newinitd "${FILESDIR}"/imap4d.initd imap4d
+ newinitd "${FILESDIR}"/pop3d.initd pop3d
+ newinitd "${FILESDIR}"/comsatd.initd comsatd
+ fi
+
+ dodoc AUTHORS ChangeLog NEWS README* THANKS TODO
+
+ # compatibility link
+ use clients && dosym /usr/bin/mail /bin/mail
+
+ use static-libs || find "${D}" -name "*.la" -delete
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize mailutils
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup mailutils
+ fi
+}
diff --git a/net-mail/mailutils/metadata.xml b/net-mail/mailutils/metadata.xml
new file mode 100644
index 0000000000..e351bcb30e
--- /dev/null
+++ b/net-mail/mailutils/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-mail</herd>
+<use>
+ <flag name="tokyocabinet">Enable Tokyo Cabinet database support</flag>
+ <flag name="clients">Build client programs - frm maidag mail sieve messages readmsg dotlock movemail mimeview mh</flag>
+ <flag name="servers">Build server programs - imap4d pop3d comsatd</flag>
+</use>
+</pkgmetadata>