summaryrefslogtreecommitdiff
path: root/net-p2p
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2016-01-31 10:52:38 +0800
committerIan Delaney <idella4@gentoo.org>2016-01-31 10:53:36 +0800
commite18457fdc7da1b9ccb31217595e4300cf831bbab (patch)
tree37264be481e279cfc26860d57e6e172848e444a9 /net-p2p
parent08ac1f1b1d7e65c83757c680004b44549d69867f (diff)
parent27aa78a3cb3996720d7d6c25f42efab4ebaac2a8 (diff)
downloadgentoo-e18457fdc7da1b9ccb31217595e4300cf831bbab.tar.gz
Merge remote-tracking branch 'remotes/sbraz/torrentinfo'
Pull request: #https://github.com/gentoo/gentoo/pull/751
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild12
1 files changed, 5 insertions, 7 deletions
diff --git a/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild b/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild
index 6329cf3b8e..0a9fdc67e6 100644
--- a/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild
+++ b/net-p2p/torrentinfo/torrentinfo-1.8.6.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
inherit distutils-r1
@@ -16,11 +16,9 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="test"
-RDEPEND=""
-DEPEND="${RDEPEND}
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
-"
+DEPEND="test? ( dev-python/nose[${PYTHON_USEDEP}] )"
python_test() {
- nosetests -v test/tests.py || die "Tests fail with ${EPYTHON}"
+ # tests sometimes fail, see bug #493682
+ nosetests test/tests.py || die "tests failed with ${EPYTHON}"
}