summaryrefslogtreecommitdiff
path: root/sci-mathematics/jags
diff options
context:
space:
mode:
authorXavier Fernández i Marín <xavier.fim@gmail.com>2015-10-30 10:05:15 +0100
committerXavier Fernández i Marín <xavier.fim@gmail.com>2015-10-30 10:05:15 +0100
commit241a72969aecd4e8c67dadfede0b867f51b4df92 (patch)
treea1ee79e44a3f085e897ba19da0ea718aa07eb850 /sci-mathematics/jags
parentbda266b5c4f438db42b189be40ad50865a7e61e3 (diff)
downloadgentoo-241a72969aecd4e8c67dadfede0b867f51b4df92.tar.gz
sci-mathematics/jags Version bump (solves bug #562644).
Diffstat (limited to 'sci-mathematics/jags')
-rw-r--r--sci-mathematics/jags/Manifest1
-rw-r--r--sci-mathematics/jags/jags-4.0.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/jags/Manifest b/sci-mathematics/jags/Manifest
index 345adf71ae..a6e7e9e866 100644
--- a/sci-mathematics/jags/Manifest
+++ b/sci-mathematics/jags/Manifest
@@ -1 +1,2 @@
DIST JAGS-3.4.0.tar.gz 1677450 SHA256 2beaa9a2672c2c95efc55ffa4c8b597a872f20232373daebd17ad539d3d7d82b SHA512 7a330ea41eab63b23d8ae3622c6920f0dc3dba653a18256957b9b862bb86b746ff706e9e9bf3f806524250b439161a6df4ad05af682354073f9b0074f9825896 WHIRLPOOL 48f2bf92f80ea0558697701320e142a61b3eb5cfefe234973a6a189096b7887ec5ea829f8f6183bf9ad4a0f6fb07d769c710b721ec1e211772cbeaea0187c8e2
+DIST JAGS-4.0.0.tar.gz 1880476 SHA256 a1d572269029d90d4e8b25757fd7ae9678994bd682937ec505ddcf06185d2c4c SHA512 bbe4f4600dff0fc1db6f8548b8d386ea804174d69788646681de6d006a0e0ab018fb01257b5737f871d10c8b59865950fb91b6a9cad5d1e6addc415004c6f82c WHIRLPOOL d1f2ad15834252c63300259c789f69ca0fa008d0c2008d504db2c394642f7a63180baae76bc272a33a92c83addc373fd9ce026063ea74b40397ac902c2272aed
diff --git a/sci-mathematics/jags/jags-4.0.0.ebuild b/sci-mathematics/jags/jags-4.0.0.ebuild
new file mode 100644
index 0000000000..a790fd62f3
--- /dev/null
+++ b/sci-mathematics/jags/jags-4.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils toolchain-funcs
+
+MYP="JAGS-${PV}"
+
+DESCRIPTION="Just Another Gibbs Sampler for Bayesian MCMC simulation"
+HOMEPAGE="http://mcmc-jags.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/mcmc-jags/JAGS/4.x/Source/${MYP}.tar.gz"
+LICENSE="GPL-2"
+IUSE="doc"
+
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ virtual/blas
+ virtual/lapack"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ virtual/latex-base
+ dev-texlive/texlive-latexextra
+ )"
+
+S="${WORKDIR}/${MYP}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
+ --with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo docs)
+}
+
+src_install() {
+ autotools-utils_src_install
+ use doc && dodoc "${BUILD_DIR}"/doc/manual/*.pdf
+}