summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellflynn
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/gkrellflynn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/gkrellflynn')
-rw-r--r--x11-plugins/gkrellflynn/Manifest1
-rw-r--r--x11-plugins/gkrellflynn/files/gkrellflynn-0.8-makefile.patch37
-rw-r--r--x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild25
-rw-r--r--x11-plugins/gkrellflynn/metadata.xml5
4 files changed, 68 insertions, 0 deletions
diff --git a/x11-plugins/gkrellflynn/Manifest b/x11-plugins/gkrellflynn/Manifest
new file mode 100644
index 0000000000..4ab1ac745a
--- /dev/null
+++ b/x11-plugins/gkrellflynn/Manifest
@@ -0,0 +1 @@
+DIST gkrellflynn-0.8.tar.gz 26722 SHA256 377c8581c15e83948687cc22c0ddee208c65195687df68dd05e73bafa7e68659 SHA512 36c643adcfb1ecb994eb6c2bb590225df1f268e885508ede28ea8b9760bdca33bfb48821d356ce0c56e38be5f7b16ad7062bc191e8a77aef1c792bd02da2f366 WHIRLPOOL dbf98ce6383443d57511cb7d4f05a50f78c1a7a39e8d97e40fef42005657984f64f65d711bb236aeb81c7a20a2436b58617a9d8d2f2f55125e0412dfffcc814b
diff --git a/x11-plugins/gkrellflynn/files/gkrellflynn-0.8-makefile.patch b/x11-plugins/gkrellflynn/files/gkrellflynn-0.8-makefile.patch
new file mode 100644
index 0000000000..0b539fa663
--- /dev/null
+++ b/x11-plugins/gkrellflynn/files/gkrellflynn-0.8-makefile.patch
@@ -0,0 +1,37 @@
+--- Makefile 2002-05-07 10:04:49.000000000 +0200
++++ Makefile_new 2013-03-12 21:10:15.888656809 +0100
+@@ -3,11 +3,10 @@
+ #
+ # updated for gkrellm2.0
+
+-CC = gcc
+-CFLAGS = -c -O -Wall -fPIC `${EXTRACONF}`
++CC = $(CC)
++INCLUDE = -c -fPIC `${EXTRACONF}`
+
+-LD = $(CC)
+-LDFLAGS = -shared -Wl -o
++LDFLAGS = $(LDFLAGS)
+ INCPATH = -I.
+ INCPATH += ${GKRELL_INC}
+
+@@ -25,10 +24,10 @@
+ (make GKRELL_INC=-DGKRELLM EXTRACONF="gtk-config --cflags;imlib-config --cflags-gdk" ${TARGET})
+
+ gkrellm2:
+- (make GKRELL_INC=-DGKRELLM2 EXTRACONF="pkg-config --cflags gtk+-2.0 gthread-2.0" ${TARGET})
++ ($(MAKE) GKRELL_INC=-DGKRELLM2 EXTRACONF="pkg-config --cflags gtk+-2.0 gthread-2.0" ${TARGET})
+
+ ${TARGET}: ${OBJS}
+- ${LD} ${DEBUG} ${LDFLAGS} ${TARGET} ${OBJS}
++ ${CC} -shared ${LDFLAGS} ${CFLAGS} -o ${TARGET} ${OBJS}
+
+ clean:
+ rm -f ${OBJS}
+@@ -47,5 +46,5 @@
+ ./install-sub.sh ${TARGET} gkrellm2
+
+ %.o : %.c
+- ${CC} ${CFLAGS} $(INCPATH) -o $@ $<
++ ${CC} ${CFLAGS} $(INCLUDE) ${LDFLAGS} $(INCPATH) -o $@ $<
+
diff --git a/x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild b/x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild
new file mode 100644
index 0000000000..86c5914f30
--- /dev/null
+++ b/x11-plugins/gkrellflynn/gkrellflynn-0.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+inherit eutils gkrellm-plugin toolchain-funcs
+
+HOMEPAGE="http://bax.comlab.uni-rostock.de/en/projects/flynn.html"
+SRC_URI="http://bax.comlab.uni-rostock.de/fileadmin/downloads/${P}.tar.gz"
+DESCRIPTION="A funny GKrellM2 load monitor (for Doom(tm) fans)"
+KEYWORDS="alpha amd64 ppc sparc x86"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+RDEPEND="app-admin/gkrellm[X]"
+DEPEND="${RDEPEND}"
+
+src_prepare(){
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" gkrellm2
+}
diff --git a/x11-plugins/gkrellflynn/metadata.xml b/x11-plugins/gkrellflynn/metadata.xml
new file mode 100644
index 0000000000..a03f5d8b38
--- /dev/null
+++ b/x11-plugins/gkrellflynn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-dock</herd>
+</pkgmetadata>