summaryrefslogtreecommitdiff
path: root/app-vim/vimclojure/vimclojure-2.3.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimclojure/vimclojure-2.3.6.ebuild')
-rw-r--r--app-vim/vimclojure/vimclojure-2.3.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/vimclojure/vimclojure-2.3.6.ebuild b/app-vim/vimclojure/vimclojure-2.3.6.ebuild
new file mode 100644
index 0000000000..52d177f62a
--- /dev/null
+++ b/app-vim/vimclojure/vimclojure-2.3.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="VimClojure"
+
+DESCRIPTION="vim plugin: Clojure syntax highlighting, filetype and indent settings"
+HOMEPAGE="https://github.com/vim-scripts/VimClojure"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/archive/${PV}.zip"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_prepare() {
+ find "${S}" -type f -name \*.bat -exec rm -v {} \; || die
+}
+
+src_install() {
+ local my_license="doc/LICENSE.txt"
+ dodoc ${my_license}
+ rm -v ${my_license} || die
+ vim-plugin_src_install
+}