summaryrefslogtreecommitdiff
path: root/dev-python/Kivy/Kivy-1.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Kivy/Kivy-1.8.0.ebuild')
-rw-r--r--dev-python/Kivy/Kivy-1.8.0.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/Kivy/Kivy-1.8.0.ebuild b/dev-python/Kivy/Kivy-1.8.0.ebuild
deleted file mode 100644
index af6192ab72..0000000000
--- a/dev-python/Kivy/Kivy-1.8.0.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A software library for rapid development of hardware-accelerated multitouch applications"
-HOMEPAGE="http://kivy.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cairo camera doc examples garden gstreamer spell"
-
-RDEPEND="
- dev-python/pygame[${PYTHON_USEDEP}]
- virtual/python-imaging[${PYTHON_USEDEP}]
- cairo? ( dev-python/pycairo[${PYTHON_USEDEP}] )
- camera? ( media-libs/opencv )
- garden? ( dev-python/kivy-garden[${PYTHON_USEDEP}] )
- gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )
- spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
- "
-RDEPEND="${DEPEND}
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -e '/data_files=/d' -i "${S}/setup.py" || die
- epatch "${FILESDIR}/cython-fixes.patch"
- if has_version '>=dev-python/cython-0.22' ; then
- epatch "${FILESDIR}/cython-0.22.patch"
- fi
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- use doc && DOCS=( doc/sources/. )
- use examples && EXAMPLES=( examples )
- distutils-r1_python_install_all
-}