summaryrefslogtreecommitdiff
path: root/dev-python/pexpect
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pexpect')
-rw-r--r--dev-python/pexpect/Manifest3
-rw-r--r--dev-python/pexpect/metadata.xml2
-rw-r--r--dev-python/pexpect/pexpect-2.4-r1.ebuild26
-rw-r--r--dev-python/pexpect/pexpect-2.4.ebuild35
-rw-r--r--dev-python/pexpect/pexpect-3.0.ebuild29
-rw-r--r--dev-python/pexpect/pexpect-4.0.1-r1.ebuild51
-rw-r--r--dev-python/pexpect/pexpect-4.0.1.ebuild51
7 files changed, 104 insertions, 93 deletions
diff --git a/dev-python/pexpect/Manifest b/dev-python/pexpect/Manifest
index 8e1f71c553..a8e98a9552 100644
--- a/dev-python/pexpect/Manifest
+++ b/dev-python/pexpect/Manifest
@@ -1,3 +1,2 @@
-DIST pexpect-2.4.tar.gz 113251 SHA256 43c788f59dcf4bed677fd0b16891787dbf747e210ffedb6e90156fbbbd4d3b7b SHA512 0d5db34f3dc0e1a5bf7d8d0ab584897e4142592f35765762e4ca60d112106b91485098c91ad95a3cb3ad1f3d600619fa0ad41d930085e75974d78e0f06280a9f WHIRLPOOL 587a94b785645a950a643bff7bf972af285faea9dcf73064eb40e96d7cb29e87543bb14c65cdc2366573236ec56cc03c4076bc952899e567872628ff5c4d9785
-DIST pexpect-3.0.tar.gz 146662 SHA256 1d6cee0fa5ab212f9ddac9852bab0df5fff11a173ed1bfde9346d5c8aa42d14c SHA512 f84cbc843978baf0ab05bae63dd080d4ca14e8fd51de4e53cf33ddb6219c9e460f68861e44104a59ddb2c1b9dc8568bc87ee778ea52b10e18e365b771ca9aa63 WHIRLPOOL e2def4eb61007d5cbb5370daa82672f6063bf87a2a238237720652f85051bb72383b4d808c8a7148063fafe020ce1253a83f97237594b52a75f8a49689e38171
DIST pexpect-3.3.tar.gz 132330 SHA256 dfea618d43e83cfff21504f18f98019ba520f330e4142e5185ef7c73527de5ba SHA512 66cc501f1c7bb8ba0be4cdc0db840629f51416dc54ae44dc770adb38f1a385116b0a8b9bc7f1cc1447f05ede36ef1b519f5c4e710e6cb736c923ecfc87497cfa WHIRLPOOL e708e722d4e2598958f8d724b84148608e9a53041077b1a1a2af84d5281e11f0c6c050ee88489eebc48bd5556c22e0fe9386680d34b1941ddf21539296629513
+DIST pexpect-4.0.1.tar.gz 143657 SHA256 232795ebcaaf2e120396dbbaa3a129eda51757eeaae1911558f4ef8ee414fc6c SHA512 c2476f977964379faa3ecef1bc4800f3a87bd6cdd9e2d52e4e4f33a4060a97bb54f0770dfb5804d5a863eaf6ddef6b11be1d24f1617cc4837015202868ca7e87 WHIRLPOOL 91bc9e259f547b34d6a8847f3154601487e5f4d0ce1d7698078eb653fc12209c4d708f902e00cfb483f3872ce42063d65d8900dcaf9c727421f5e8b3d730e076
diff --git a/dev-python/pexpect/metadata.xml b/dev-python/pexpect/metadata.xml
index b4c5048d4c..4342adeb1f 100644
--- a/dev-python/pexpect/metadata.xml
+++ b/dev-python/pexpect/metadata.xml
@@ -1,4 +1,4 @@
-<?xml version='1.0' encoding='UTF-8'?>
+<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
diff --git a/dev-python/pexpect/pexpect-2.4-r1.ebuild b/dev-python/pexpect/pexpect-2.4-r1.ebuild
deleted file mode 100644
index 3af10444db..0000000000
--- a/dev-python/pexpect/pexpect-2.4-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
-HOMEPAGE="http://pexpect.sourceforge.net/ https://pypi.python.org/pypi/pexpect"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples"
-
-DEPEND=""
-RDEPEND=""
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pexpect/pexpect-2.4.ebuild b/dev-python/pexpect/pexpect-2.4.ebuild
deleted file mode 100644
index ca9e593741..0000000000
--- a/dev-python/pexpect/pexpect-2.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-PYTHON_DEPEND="2"
-
-inherit distutils
-
-DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
-HOMEPAGE="http://pexpect.sourceforge.net/ https://pypi.python.org/pypi/pexpect"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples"
-
-DEPEND=""
-RDEPEND=""
-RESTRICT_PYTHON_ABIS="3.*"
-
-PYTHON_MODNAME="ANSI.py fdpexpect.py FSM.py pexpect.py pxssh.py screen.py"
-
-src_install() {
- distutils_src_install
-
- use doc && dohtml -r doc/*
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
diff --git a/dev-python/pexpect/pexpect-3.0.ebuild b/dev-python/pexpect/pexpect-3.0.ebuild
deleted file mode 100644
index 49e06cd6bb..0000000000
--- a/dev-python/pexpect/pexpect-3.0.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
-HOMEPAGE="http://pexpect.sourceforge.net/ https://pypi.python.org/pypi/pexpect"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 ~arm hppa ~ia64 ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples"
-
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pexpect/pexpect-4.0.1-r1.ebuild b/dev-python/pexpect/pexpect-4.0.1-r1.ebuild
new file mode 100644
index 0000000000..8071929a5e
--- /dev/null
+++ b/dev-python/pexpect/pexpect-4.0.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
+HOMEPAGE="
+ http://pexpect.sourceforge.net/
+ https://pypi.python.org/pypi/pexpect/
+ https://github.com/pexpect/pexpect/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/ptyprocess-0.5[${PYTHON_USEDEP}]"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # tests failing
+ # https://github.com/pexpect/pexpect/issues/282
+ # https://github.com/pexpect/pexpect/issues/283
+ # https://github.com/pexpect/pexpect/issues/284
+ rm tests/test_maxcanon.py tests/test_async.py || die
+ touch .coveragerc || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pexpect/pexpect-4.0.1.ebuild b/dev-python/pexpect/pexpect-4.0.1.ebuild
new file mode 100644
index 0000000000..33a957104d
--- /dev/null
+++ b/dev-python/pexpect/pexpect-4.0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for spawning child applications and responding to expected patterns"
+HOMEPAGE="
+ http://pexpect.sourceforge.net/
+ https://pypi.python.org/pypi/pexpect/
+ https://github.com/pexpect/pexpect/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/ptyprocess-0.5[${PYTHON_USEDEP}]"
+DEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # tests failing
+ # https://github.com/pexpect/pexpect/issues/282
+ # https://github.com/pexpect/pexpect/issues/283
+ # https://github.com/pexpect/pexpect/issues/284
+ rm tests/test_maxcanon.py tests/test_async.py || die
+ touch .coveragerc || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ py.test tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}