summaryrefslogtreecommitdiff
path: root/dev-ros/rosserial_xbee/rosserial_xbee-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rosserial_xbee/rosserial_xbee-9999.ebuild')
-rw-r--r--dev-ros/rosserial_xbee/rosserial_xbee-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosserial_xbee/rosserial_xbee-9999.ebuild b/dev-ros/rosserial_xbee/rosserial_xbee-9999.ebuild
new file mode 100644
index 0000000000..4e1c019f47
--- /dev/null
+++ b/dev-ros/rosserial_xbee/rosserial_xbee-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-drivers/rosserial"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tools to do point to multipoint communication between rosserial nodes connected to an xbee"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ dev-ros/rosserial_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosserial_python[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"