summaryrefslogtreecommitdiff
path: root/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.3.0.ebuild')
-rw-r--r--dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.3.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.3.0.ebuild b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.3.0.ebuild
new file mode 100644
index 0000000000..d424d4a558
--- /dev/null
+++ b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.3.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="FastGettext / Rails integration"
+HOMEPAGE="https://github.com/grosser/gettext_i18n_rails"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rails:4.0 dev-ruby/activerecord:4.0[sqlite] dev-ruby/temple )"
+ruby_add_rdepend ">=dev-ruby/fast_gettext-0.9.0"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+
+ # Remove specs for slim and hamlet, template engines we don't package.
+ rm spec/gettext_i18n_rails/slim_parser_spec.rb spec/gettext_i18n_rails/haml_parser_spec.rb || die
+
+ # Test against Rails 4.0 (newer versions don't work and we don't use
+ # appraisals for now).
+ sed -e '1igem "rails", "~>4.2.0"' -i spec/spec_helper.rb || die
+}