summaryrefslogtreecommitdiff
path: root/games-emulation/mupen64plus-video-glide64mk2
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/mupen64plus-video-glide64mk2')
-rw-r--r--games-emulation/mupen64plus-video-glide64mk2/Manifest1
-rw-r--r--games-emulation/mupen64plus-video-glide64mk2/metadata.xml1
-rw-r--r--games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.ebuild (renamed from games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.0.ebuild)26
3 files changed, 16 insertions, 12 deletions
diff --git a/games-emulation/mupen64plus-video-glide64mk2/Manifest b/games-emulation/mupen64plus-video-glide64mk2/Manifest
index 891c395ef0..36dbc5e4c8 100644
--- a/games-emulation/mupen64plus-video-glide64mk2/Manifest
+++ b/games-emulation/mupen64plus-video-glide64mk2/Manifest
@@ -1 +1,2 @@
DIST mupen64plus-video-glide64mk2-src-2.0.tar.gz 445166 SHA256 7761594432e90aed2dd12a5f16b30674c65b1f1abad0d98ac6239c3b2c44a4d5 SHA512 043b84927219b574da3c489119007bd115c9fa0f3f476ea9e812c8321a7f1e9309af06bed0b975c00201bc35f925d3b85c3411aa02310fd1ea508191184afa9a WHIRLPOOL b55c7412139b5b31fc919947068a7ad06958b20e54b9ac350cac88af3fec0d03d4f36675c1b60ba330061e652d489113bd7b84f53e7677c3cc1f0039c2a135af
+DIST mupen64plus-video-glide64mk2-src-2.5.tar.gz 488988 SHA256 ef3dae0084e078d843605abdf5039eb8b5dd68ff1410b4fc12bdf19592a9fcb6 SHA512 b62620a364ca9e6bf729e5dd07fb84a73745c6533b95468d3f5411c0556824282f760efefea0968b0a9282f77c315bbed8b0b8a59d771893b7fd0f5f24ad725d WHIRLPOOL 63068d428d5a00a52911155e39cdd09ee79d1ca2d47b005799bf25e4438a476271aa786a3227d9f77e7cb80fe20b18906a70f7829947dbfb2f8d04ffd3da4e18
diff --git a/games-emulation/mupen64plus-video-glide64mk2/metadata.xml b/games-emulation/mupen64plus-video-glide64mk2/metadata.xml
index 7eb8e678ad..31c4712749 100644
--- a/games-emulation/mupen64plus-video-glide64mk2/metadata.xml
+++ b/games-emulation/mupen64plus-video-glide64mk2/metadata.xml
@@ -10,6 +10,7 @@
<name>Christian Birchinger</name>
</maintainer>
<use>
+ <flag name="gles2">Use GLES2 instead of OpenGL</flag>
<flag name="hires">Support hi-resolution textures (requires <pkg>dev-libs/boost</pkg>)</flag>
</use>
<upstream>
diff --git a/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.0.ebuild b/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.ebuild
index ab10a0e3b5..eb83f47987 100644
--- a/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.0.ebuild
+++ b/games-emulation/mupen64plus-video-glide64mk2/mupen64plus-video-glide64mk2-2.5.ebuild
@@ -5,7 +5,7 @@
EAPI=5
MY_P=${PN}-src-${PV}
-inherit eutils toolchain-funcs games
+inherit eutils multilib toolchain-funcs
DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, glide64mk2 video plugin"
HOMEPAGE="http://www.mupen64plus.org/"
@@ -14,11 +14,12 @@ SRC_URI="https://github.com/mupen64plus/${PN}/releases/download/${PV}/${MY_P}.ta
LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="hires cpu_flags_x86_sse"
+IUSE="gles2 hires cpu_flags_x86_sse"
-RDEPEND="games-emulation/mupen64plus-core:0=
+RDEPEND=">=games-emulation/mupen64plus-core-2.5:0=[gles2=]
media-libs/libpng:0=
- media-libs/libsdl:0=
+ media-libs/libsdl2:0=
+ media-libs/libtxc_dxtn
sys-libs/zlib:0=
virtual/opengl:0=
hires? ( dev-libs/boost:0= )"
@@ -56,9 +57,7 @@ src_compile() {
# paths, some of them are used at compile time
PREFIX=/usr
- LIBDIR="$(games_get_libdir)"
- PLUGINDIR="$(games_get_libdir)"/mupen64plus
- SHAREDIR="${GAMES_DATADIR}"/mupen64plus
+ LIBDIR=/usr/$(get_libdir)
# disable unwanted magic
LDCONFIG=:
@@ -66,12 +65,16 @@ src_compile() {
# Package-specific stuff
- # CROSS_COMPILE causes it to look for ${CHOST}-sdl-config...
- SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl)"
- SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl)"
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl2-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl2)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl2)"
- NO_ASM=$(usex cpu_flags_x86_sse 0 1)
+ NOSSE=$(usex cpu_flags_x86_sse 0 1)
HIRES=$(usex hires 1 0)
+ USE_FRAMESKIPPER=1
+ USE_GLES=$(usex gles2 1 0)
+ # use external lib
+ TXCDXTN=1
)
use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
@@ -83,5 +86,4 @@ src_compile() {
src_install() {
emake "${MAKEARGS[@]}" DESTDIR="${D}" install
einstalldocs
- prepgamesdirs
}