summaryrefslogtreecommitdiff
path: root/net-ftp/tnftp/tnftp-20151004.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/tnftp/tnftp-20151004.ebuild')
-rw-r--r--net-ftp/tnftp/tnftp-20151004.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-ftp/tnftp/tnftp-20151004.ebuild b/net-ftp/tnftp/tnftp-20151004.ebuild
new file mode 100644
index 0000000000..8ed1dd8daa
--- /dev/null
+++ b/net-ftp/tnftp/tnftp-20151004.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="NetBSD FTP client with several advanced features"
+SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/misc/${PN}/${P}.tar.gz
+ ftp://ftp.netbsd.org/pub/NetBSD/misc/${PN}/old/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/"
+
+SLOT="0"
+LICENSE="BSD-4 BSD ISC"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ipv6 socks5"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ socks5? ( net-proxy/dante )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-editcomplete \
+ $(use_enable ipv6) \
+ $(use_with socks5 socks) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc ChangeLog README THANKS || die "dodoc failed"
+}