summaryrefslogtreecommitdiff
path: root/sci-chemistry
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/coot/coot-0.8.2-r1.ebuild2
-rw-r--r--sci-chemistry/platon/Manifest2
-rw-r--r--sci-chemistry/platon/platon-20151001.ebuild (renamed from sci-chemistry/platon/platon-20150921.ebuild)4
-rw-r--r--sci-chemistry/prody/Manifest1
-rw-r--r--sci-chemistry/prody/metadata.xml8
-rw-r--r--sci-chemistry/prody/prody-1.6.ebuild44
-rw-r--r--sci-chemistry/pymol-plugins-dynamics/Manifest1
-rw-r--r--sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.4.ebuild38
-rw-r--r--sci-chemistry/relax/Manifest5
-rw-r--r--sci-chemistry/relax/relax-3.3.4.ebuild69
-rw-r--r--sci-chemistry/relax/relax-3.3.5.ebuild69
-rw-r--r--sci-chemistry/relax/relax-3.3.6.ebuild73
-rw-r--r--sci-chemistry/relax/relax-3.3.9.ebuild (renamed from sci-chemistry/relax/relax-3.3.7.ebuild)4
13 files changed, 96 insertions, 224 deletions
diff --git a/sci-chemistry/coot/coot-0.8.2-r1.ebuild b/sci-chemistry/coot/coot-0.8.2-r1.ebuild
index 2663fba892..0f95e676b9 100644
--- a/sci-chemistry/coot/coot-0.8.2-r1.ebuild
+++ b/sci-chemistry/coot/coot-0.8.2-r1.ebuild
@@ -134,7 +134,7 @@ src_configure() {
src_test() {
source "${EPREFIX}/etc/profile.d/40ccp4.setup.sh"
- mkdir "${T}"/coot_test || die
+ mkdir "${T}"/coot_test || die
export COOT_STANDARD_RESIDUES="${S}/standard-residues.pdb"
export COOT_SCHEME_DIR="${S}/scheme/"
diff --git a/sci-chemistry/platon/Manifest b/sci-chemistry/platon/Manifest
index 8b5d3da113..c144751779 100644
--- a/sci-chemistry/platon/Manifest
+++ b/sci-chemistry/platon/Manifest
@@ -1 +1 @@
-DIST platon-20150921.tar.gz 12019784 SHA256 a667ce5ae4c60edc12776f0da9f8c481bee451d1c78b4a9edc2bd2df18ee7612 SHA512 59786d3978c11167f5f12f8f487e6e478d0bc1f070a443ca4626d830e4014122ad974d6e1e1debc2c6c6bbc37d82b7b6b6bb89ad0c74fbd061af26a639db9448 WHIRLPOOL e42d651310da8ae4108b1ec8dfaa3d556236e55889fa153fdfd90d7abbe33b70931fe78a559b0e86afc5d07cc8eb47356d91e9bf0d90a168238d8ce14875c52c
+DIST platon-20151001.tar.gz 12076455 SHA256 0f693de9b8ef601bc502d56a203c851ee350185e0816ede4b1b4d154917fa5b2 SHA512 fc93e4c425c25ddc9ae634c82b63e95c5ce99bcbada43976478a58783e3b369f082e08e2ee24ff7d9ebe2d9d2d730cd42f6361276a53bed9edd0c0476cfb5148 WHIRLPOOL 458e6a263958473bf39d460524fb98963e701d96050db5c622a6cb934796271bb45313526614b3bd28ce372e7bd6a60d76cb6aaa8e80d1e18d7fdc436a03b702
diff --git a/sci-chemistry/platon/platon-20150921.ebuild b/sci-chemistry/platon/platon-20151001.ebuild
index 70f0828dea..f4b0aaeb44 100644
--- a/sci-chemistry/platon/platon-20150921.ebuild
+++ b/sci-chemistry/platon/platon-20151001.ebuild
@@ -36,10 +36,6 @@ src_unpack() {
gunzip platon.f.gz xdrvr.c.gz || die
}
-src_prepare() {
- epatch "${FILESDIR}"/${PV}-buffer-overflow.patch
-}
-
src_compile() {
# easy to ICE, at least on gcc 4.3
strip-flags
diff --git a/sci-chemistry/prody/Manifest b/sci-chemistry/prody/Manifest
new file mode 100644
index 0000000000..df88491d4c
--- /dev/null
+++ b/sci-chemistry/prody/Manifest
@@ -0,0 +1 @@
+DIST prody-1.6.tar.gz 5333629 SHA256 db5f2223005640e64b5bfd5ef147744381b9b170ced61db7bc8f3a0fdb583c86 SHA512 d913ad45b034f1b0e7e36428a6f8f199b365b94bd85bee5ade8eb9eb2b04a18c93d894a2abd18b3a1342597725ffbf96f8ce8a49191fc27e5608f3d2c9a3c49a WHIRLPOOL a6435d88046970cca53290b258017d09b19457c4bbd5530743a3dc9cbc023ee78a28a4df81b190a5499df114d9909afff0697e571ef5bc4726311f4ea287c4be
diff --git a/sci-chemistry/prody/metadata.xml b/sci-chemistry/prody/metadata.xml
new file mode 100644
index 0000000000..ae9ec7c5f6
--- /dev/null
+++ b/sci-chemistry/prody/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/prody/prody-1.6.ebuild b/sci-chemistry/prody/prody-1.6.ebuild
new file mode 100644
index 0000000000..a2ece4dfd9
--- /dev/null
+++ b/sci-chemistry/prody/prody-1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Protein Dynamics Analysis"
+HOMEPAGE="http://prody.csb.pitt.edu/ https://github.com/prody/ProDy"
+SRC_URI="https://github.com/prody/ProDy/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.7[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+ sci-biology/biopython[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}"/ProDy-${PV}
+
+DISTUTILS_IN_SOURCE_BUILD=true
+
+python_prepare_all() {
+ emake remove
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ PATH="${S}"/scripts:${PATH} \
+ nosetests --verbose || die
+}
diff --git a/sci-chemistry/pymol-plugins-dynamics/Manifest b/sci-chemistry/pymol-plugins-dynamics/Manifest
index a607e37c50..258493d5b2 100644
--- a/sci-chemistry/pymol-plugins-dynamics/Manifest
+++ b/sci-chemistry/pymol-plugins-dynamics/Manifest
@@ -1 +1,2 @@
DIST pymol-plugins-dynamics-1.2.0.tar.gz 725163 SHA256 edf9bddbbce41ee5319bfd0b28d6e0b0eba56e8b2d8a300d510be8ff5894704f SHA512 7e8d62ea58cb88348136fccd132d9a1faaa3474c0a0f821e729ced777620e2083b1b0606d79fc75802755c96c5eb0b90e08b00e5c865ecbaaee2b837f56987de WHIRLPOOL 07061d3b0840fef0025be55b90fca013afc1ea58308d6ee11a8b74321de4f1c24760b1cf141b0a86678c5cf652c8890cdf2c4e0da60403c8454e04b003e20aaa
+DIST pymol-plugins-dynamics-2.0.4.tar.gz 821563 SHA256 358452e0d8589ffae28fe486eeca0be353f17f1fdde9f05f548025b241afabe5 SHA512 befad8b5c09ddba89b9e00bd712a2af7202e312b2ebee7722cbeec5698125dd7614463465d79c17c805714ba23ca1188c64610789e90c93bb0ad7572841ebf25 WHIRLPOOL 039e40c7c57a242476e72a351ecc099201021f479762c2eb29bdad25b72c11c33295e8f9707ece486235efb1b205524e479cd4ae57639d1410515a75d2221989
diff --git a/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.4.ebuild b/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.4.ebuild
new file mode 100644
index 0000000000..1111c61104
--- /dev/null
+++ b/sci-chemistry/pymol-plugins-dynamics/pymol-plugins-dynamics-2.0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+MY_PN="Dynamics"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Molecular dynamics in Pymol"
+HOMEPAGE="https://github.com/tomaszmakarewicz/Dynamics"
+SRC_URI="https://github.com/tomaszmakarewicz/Dynamics/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ sci-chemistry/prody[${PYTHON_USEDEP}]
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/${MY_P}
+
+DOCS=( manual.odt )
+
+src_install() {
+ python_moduleinto pmg_tk/startup
+ python_parallel_foreach_impl python_domodule pymol_plugin_dynamics.py
+}
diff --git a/sci-chemistry/relax/Manifest b/sci-chemistry/relax/Manifest
index 789564f5ef..42f7f7f33e 100644
--- a/sci-chemistry/relax/Manifest
+++ b/sci-chemistry/relax/Manifest
@@ -1,5 +1,2 @@
-DIST relax-3.3.4.src.tar.bz2 89206485 SHA256 03ecc20353126d155c7d5c9ab45e3bb146a87243472711c937befced2db333c0 SHA512 78ae5778ef0fe84fc3a26648dd2192d529fb1e5241728f7c06a5a2cec2ce849a2c75c19a931123a17d5c210acc4f4c2401574b10a1fbbe0307d2d9867567352d WHIRLPOOL 4fcdec36e8df412091ab1a99a6b017ebc72f8e5c400429e698221f22e4ef7ae35713a6e2a05f6f1b573e5223f8eccc7cb0d2a20b1171e5bc483fd3ef1a0242bc
-DIST relax-3.3.5.src.tar.bz2 90164368 SHA256 d9e3668221dba7589ba1d12ab40df517b5b6f742ee413864cc87ab636546e2ef SHA512 c8c248abf0edb54af631c11b102b641d41a106036bbdb88d8f1563c9750d3c7d402ee150d7afd770b845d3a421e431afcf95e6222197f9dc1afec61ddcd0bf37 WHIRLPOOL d9070bed833ef063c22fec5e55b1968c65b672ee100247b1af9a25d3149eb57475aeb94a4f125fc3cd278d97ac248e7826b083c840b47f9db83bae7e1aaae710
-DIST relax-3.3.6.src.tar.bz2 90005292 SHA256 2b1994626a910036c63d67c609c49b3bde8c754b60763de62c2ac8f6c3f589c3 SHA512 cda773a4af259d25550e4e4dbd8500594afd9df051ba06130355058347f308b804726acafaa76957e062c78d1d8fb26f843b3ac97d5aecd534b53c1a5155cafb WHIRLPOOL 0bf0f51664a132653fbd981ee6776cb16dd6371504df2167658027325d632cda8a6f4a21d4a530c46dc75c93b3ffb87f5189d4986acadb344154cd7420361e0b
-DIST relax-3.3.7.src.tar.bz2 90268061 SHA256 a32508bd55fa124f6472e08d89ec0fa9f3837efcceb2be681404eb998457381f SHA512 3724a51ef9177f9bd78b3c92add7b88d559f21f5166eaf62b865586c061d17ce0a1af61a794db324d0f792eece04d8f1d037f9e982c858768da1d3fc208e9270 WHIRLPOOL e4446c7ccbe1e8f3caa450a3d747fb8dfcc33d9d336386572b72481544101199150e7938b0e5319a70ef3a5a7f4ad53c143d4a6c01cc7553f435fbc0d00fe952
DIST relax-3.3.8.src.tar.bz2 90271667 SHA256 176d4e9f0f1c6cf6e6c93b12070a50ff31e10c8dbe2c05cfc2b253e51425b12d SHA512 ddc9df4a8da4ec563403003ae5bc9ecdf5f3bb7341e2306c405fcf7953ab67cab93e9f64139465b05acfa2c842da1624d941b481ef77c20804cabe7c9df811f9 WHIRLPOOL 1a7f77fc9cd712b7ca459a1943dffde4e154fa2d5e06b77ec42568b012c4319dd43eb0b85cdfd6116b9ba2584e5bd58e1b0d8ea8524d462ab4e18e33d4fa315e
+DIST relax-3.3.9.src.tar.bz2 93403953 SHA256 5bfa0fc774cfafd30e9f593f6b5f368b6bd79faf0ca2e7ae064a8bd3b6923685 SHA512 0af93497acd91e6e4be0cf07efe09198c1234e70641835668a94714d58ad225d5ef94df3225d4d6809aa456e340c05829520f4aa6215cb83f7315ccca2053461 WHIRLPOOL 4ea5bb6582a020df902b9ac28cf5e025456607ddb50b1a6c1915db421ac6ea415781cb9d361fd34b2240500e7d0b74af131984dddcea6b0548dfb76d8b2be378
diff --git a/sci-chemistry/relax/relax-3.3.4.ebuild b/sci-chemistry/relax/relax-3.3.4.ebuild
deleted file mode 100644
index e394217054..0000000000
--- a/sci-chemistry/relax/relax-3.3.4.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-WX_GTK_VER="2.9"
-
-inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
-
-DESCRIPTION="Molecular dynamics by NMR data analysis"
-HOMEPAGE="http://www.nmr-relax.com/"
-SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-python/Numdifftools[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
- sci-chemistry/molmol
- sci-chemistry/pymol[${PYTHON_USEDEP}]
- sci-chemistry/vmd
- >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
- >=sci-libs/minfx-1.0.11[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- sci-visualization/grace
- sci-visualization/opendx
- x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="${RDEPEND}
- media-gfx/pngcrush"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- rm -rf minfx bmrblib extern/numdifftools || die
- tc-export CC
-}
-
-src_compile() {
- escons
-}
-
-src_test() {
- VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
- virtualmake
-}
-
-src_install() {
- dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf}
-
- python_moduleinto ${PN}
- python_domodule *
-
- rm ${PN} README || die
-
- make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
-}
diff --git a/sci-chemistry/relax/relax-3.3.5.ebuild b/sci-chemistry/relax/relax-3.3.5.ebuild
deleted file mode 100644
index 154bc9af2c..0000000000
--- a/sci-chemistry/relax/relax-3.3.5.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-WX_GTK_VER="2.9"
-
-inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
-
-DESCRIPTION="Molecular dynamics by NMR data analysis"
-HOMEPAGE="http://www.nmr-relax.com/"
-SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-python/Numdifftools[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
- sci-chemistry/molmol
- sci-chemistry/pymol[${PYTHON_USEDEP}]
- sci-chemistry/vmd
- >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
- >=sci-libs/minfx-1.0.11[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- sci-visualization/grace
- sci-visualization/opendx
- x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="${RDEPEND}
- media-gfx/pngcrush"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- rm -rf minfx bmrblib extern/numdifftools || die
- tc-export CC
-}
-
-src_compile() {
- escons
-}
-
-src_test() {
- VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
- virtualmake
-}
-
-src_install() {
- dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf}
-
- python_moduleinto ${PN}
- python_domodule *
-
- rm ${PN} README || die
-
- make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
-}
diff --git a/sci-chemistry/relax/relax-3.3.6.ebuild b/sci-chemistry/relax/relax-3.3.6.ebuild
deleted file mode 100644
index b8a571cbdc..0000000000
--- a/sci-chemistry/relax/relax-3.3.6.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-WX_GTK_VER="2.9"
-
-inherit eutils multiprocessing python-single-r1 scons-utils toolchain-funcs wxwidgets virtualx
-
-DESCRIPTION="Molecular dynamics by NMR data analysis"
-HOMEPAGE="http://www.nmr-relax.com/"
-SRC_URI="http://download.gna.org/relax/${P}.src.tar.bz2"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-python/Numdifftools[${PYTHON_USEDEP}]
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/wxpython:${WX_GTK_VER}[${PYTHON_USEDEP}]
- sci-chemistry/molmol
- sci-chemistry/pymol[${PYTHON_USEDEP}]
- sci-chemistry/vmd
- >=sci-libs/bmrblib-1.0.3[${PYTHON_USEDEP}]
- >=sci-libs/minfx-1.0.11[${PYTHON_USEDEP}]
- sci-libs/scipy[${PYTHON_USEDEP}]
- sci-visualization/grace
- sci-visualization/opendx
- x11-libs/wxGTK:${WX_GTK_VER}[X]"
-DEPEND="${RDEPEND}
- media-gfx/pngcrush
- test? (
- ${RDEPEND}
- )
- "
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- rm -rf minfx bmrblib extern/numdifftools || die
- tc-export CC
-}
-
-src_compile() {
- escons
-}
-
-src_test() {
- VIRTUALX_COMMAND="${EPYTHON} ./${PN}.py -x --traceback"
- virtualmake
-}
-
-src_install() {
- dodoc README docs/{CHANGES,COMMITTERS,JOBS,relax.pdf}
-
- python_moduleinto ${PN}
- python_domodule *
-
- rm ${PN} README || die
-
- make_wrapper ${PN}-nmr "${EPYTHON} $(python_get_sitedir)/${PN}/${PN}.py $@"
-}
diff --git a/sci-chemistry/relax/relax-3.3.7.ebuild b/sci-chemistry/relax/relax-3.3.9.ebuild
index b8a571cbdc..5ffdf92275 100644
--- a/sci-chemistry/relax/relax-3.3.7.ebuild
+++ b/sci-chemistry/relax/relax-3.3.9.ebuild
@@ -38,9 +38,7 @@ RDEPEND="
x11-libs/wxGTK:${WX_GTK_VER}[X]"
DEPEND="${RDEPEND}
media-gfx/pngcrush
- test? (
- ${RDEPEND}
- )
+ test? ( ${RDEPEND} )
"
pkg_setup() {