summaryrefslogtreecommitdiff
path: root/x11-libs/vte/vte-0.38.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/vte/vte-0.38.3.ebuild')
-rw-r--r--x11-libs/vte/vte-0.38.3.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/x11-libs/vte/vte-0.38.3.ebuild b/x11-libs/vte/vte-0.38.3.ebuild
deleted file mode 100644
index 88937da529..0000000000
--- a/x11-libs/vte/vte-0.38.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-GCONF_DEBUG="no"
-VALA_USE_DEPEND="vapigen"
-
-inherit eutils gnome2 vala
-
-DESCRIPTION="Library providing a virtual terminal emulator widget"
-HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
-
-LICENSE="LGPL-2+"
-SLOT="2.91"
-IUSE="debug glade +introspection vala"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
-
-PDEPEND=">=x11-libs/gnome-pty-helper-${PV}"
-RDEPEND="
- >=dev-libs/glib-2.40:2
- >=x11-libs/gtk+-3.8:3[introspection?]
- >=x11-libs/pango-1.22.0
-
- sys-libs/ncurses:0=
- x11-libs/libX11
- x11-libs/libXft
-
- glade? ( >=dev-util/glade-3.9:3.10 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
-"
-DEPEND="${RDEPEND}
- $(vala_depend)
- >=dev-util/gtk-doc-am-1.13
- >=dev-util/intltool-0.35
- sys-devel/gettext
- virtual/pkgconfig
-"
-RDEPEND="${RDEPEND}
- !x11-libs/vte:2.90[glade]
-"
-
-src_prepare() {
- vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- local myconf=""
-
- if [[ ${CHOST} == *-interix* ]]; then
- myconf="${myconf} --disable-Bsymbolic"
-
- # interix stropts.h is empty...
- export ac_cv_header_stropts_h=no
- fi
-
- # Python bindings are via gobject-introspection
- # Ex: from gi.repository import Vte
- # Do not disable gnome-pty-helper, bug #401389
- gnome2_src_configure \
- --disable-deprecation \
- --disable-test-application \
- --disable-static \
- $(use_enable debug) \
- $(use_enable glade glade-catalogue) \
- $(use_enable introspection) \
- $(use_enable vala) \
- ${myconf}
-}
-
-src_install() {
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
- gnome2_src_install
- mv "${D}"/etc/profile.d/vte{,-${SLOT}}.sh || die
-}