aboutsummaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorMarat Dukhan <maratek@gmail.com>2018-06-05 03:36:26 -0700
committerDominic Hamon <dominichamon@users.noreply.github.com>2018-06-05 11:36:26 +0100
commit7fb3c564e51ce3aa6100484a0b25c603ea5fd123 (patch)
treeaf1b295439f04462a43d49260053d234570cca51 /test/CMakeLists.txt
parent4c2af0788977d3bd900585528c2d08b875b2cd39 (diff)
downloadgoogle-benchmark-7fb3c564e51ce3aa6100484a0b25c603ea5fd123.tar.gz
Fix compilation on Android with GNU STL (#596)
* Fix compilation on Android with GNU STL GNU STL in Android NDK lacks string conversion functions from C++11, including std::stoul, std::stoi, and std::stod. This patch reimplements these functions in benchmark:: namespace using C-style equivalents from C++03. * Avoid use of log2 which doesn't exist in Android GNU STL GNU STL in Android NDK lacks log2 function from C99/C++11. This patch replaces their use in the code with double log(double) function.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 05ae804..f49ca51 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -180,6 +180,7 @@ if (BENCHMARK_ENABLE_GTEST_TESTS)
add_gtest(benchmark_gtest)
add_gtest(statistics_gtest)
+ add_gtest(string_util_gtest)
endif(BENCHMARK_ENABLE_GTEST_TESTS)
###############################################################################