aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEsun Kim <veblush@google.com>2021-12-02 15:22:44 -0800
committerGitHub <noreply@github.com>2021-12-02 15:22:44 -0800
commit260145c517f1f5836ddd60a7b7415b59540f2faf (patch)
treeceec62c187ab1cf651136c7c67a7664e880ba66a /setup.py
parentc007ea297cceabe4ce67f828cf8fd8a6659cf8e7 (diff)
downloadgrpc-grpc-260145c517f1f5836ddd60a7b7415b59540f2faf.tar.gz
Updated backoff to use absl::Random (#27193)
* Replace in-house rand with absl::Random for backoff (#26463) * Replace in-house rand with absl::Random for backoff * Run sanity * Added bscrypt dependency * Removed ABSL_RANDOM_HWAES_FLAGS * Remove GCC_WARN_64_TO_32_BIT_CONVERSION = YES * GCC_WARN_64_TO_32_BIT_CONVERSION to podspec install
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1a72c5c668..62dc98ed4e 100644
--- a/setup.py
+++ b/setup.py
@@ -312,8 +312,9 @@ if not "win32" in sys.platform:
if "win32" in sys.platform:
EXTENSION_LIBRARIES += (
'advapi32',
- 'ws2_32',
+ 'bcrypt',
'dbghelp',
+ 'ws2_32',
)
if BUILD_WITH_SYSTEM_OPENSSL:
EXTENSION_LIBRARIES += (