aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAlberto Pedron <albertop2197@gmail.com>2021-12-15 20:09:12 +0100
committerGitHub <noreply@github.com>2021-12-15 11:09:12 -0800
commitc1fe2bc130c8bf9deb99577dd64b40727dea795c (patch)
tree9a605ff28e8dcba4862505fe4cce3ce2025a7e17 /setup.py
parentecf946e3a4bd795a05134f2440b32a62353851c0 (diff)
downloadgrpc-grpc-c1fe2bc130c8bf9deb99577dd64b40727dea795c.tar.gz
Fix libatomic linking on Rasperry Pi OS Bullseye (#28041)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 62dc98ed4e..f149d5efaa 100644
--- a/setup.py
+++ b/setup.py
@@ -210,7 +210,7 @@ def check_linker_need_libatomic():
# Double-check to see if -latomic actually can solve the problem.
# https://github.com/grpc/grpc/issues/22491
cpp_test = subprocess.Popen(
- [cxx, '-x', 'c++', '-std=c++11', '-latomic', '-'],
+ [cxx, '-x', 'c++', '-std=c++11', '-', '-latomic'],
stdin=PIPE,
stdout=PIPE,
stderr=PIPE)