aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorKhaled Hosny <khaled@aliftype.com>2022-08-02 23:46:04 +0200
committerخالد حسني (Khaled Hosny) <khaled@aliftype.com>2022-08-03 00:07:40 +0200
commit16bfe6536b32f6a83fcbf53bd445d222d74fa638 (patch)
tree51a6947dcd88fd8f2f783f816a170dbccae22dbb /meson.build
parentee18ae3b76bce1d9dafcfdcc0bb049e099120c61 (diff)
downloadharfbuzz_ng-16bfe6536b32f6a83fcbf53bd445d222d74fa638.tar.gz
[meson] use cpp.get_argument_syntax not cpp.get_id
To account for both MSVC and clang-cl. Fixes https://github.com/harfbuzz/harfbuzz/issues/3756
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index df4443fb2..e4a38d3f0 100644
--- a/meson.build
+++ b/meson.build
@@ -21,7 +21,7 @@ pkgmod = import('pkgconfig')
cpp = meson.get_compiler('cpp')
null_dep = dependency('', required: false)
-if cpp.get_id() == 'msvc'
+if cpp.get_argument_syntax() == 'msvc'
# Ignore several spurious warnings for things HarfBuzz does very commonly.
# If a warning is completely useless and spammy, use '/wdXXXX' to suppress it
# If a warning is harmless but hard to fix, use '/woXXXX' so it's shown once
@@ -118,7 +118,7 @@ if not get_option('cairo').disabled()
cairo_ft_dep = dependency('cairo-ft', required: false)
if (not cairo_dep.found() and
- cpp.get_id() == 'msvc' and
+ cpp.get_argument_syntax() == 'msvc' and
cpp.has_header('cairo.h'))
cairo_dep = cpp.find_library('cairo', required: false)
if cairo_dep.found() and cpp.has_function('cairo_ft_font_face_create_for_ft_face',