aboutsummaryrefslogtreecommitdiff
path: root/test/shape/data/in-house/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/shape/data/in-house/Makefile.am')
-rw-r--r--test/shape/data/in-house/Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/test/shape/data/in-house/Makefile.am b/test/shape/data/in-house/Makefile.am
index a2845785e..2ecf1fb29 100644
--- a/test/shape/data/in-house/Makefile.am
+++ b/test/shape/data/in-house/Makefile.am
@@ -14,10 +14,18 @@ EXTRA_DIST = \
$(NULL)
TEST_EXTENSIONS = .tests
+TESTS_ENVIRONMENT =
if HAVE_FREETYPE
-TESTS_ENVIRONMENT = HAVE_FREETYPE=1
-else
-TESTS_ENVIRONMENT = HAVE_FREETYPE=0
+TESTS_ENVIRONMENT += HAVE_FREETYPE=1
+endif
+if HAVE_CORETEXT
+TESTS_ENVIRONMENT += HAVE_CORETEXT=1
+endif
+if HAVE_DIRECTWRITE
+TESTS_ENVIRONMENT += HAVE_DIRECTWRITE=1
+endif
+if HAVE_UNISCRIBE
+TESTS_ENVIRONMENT += HAVE_UNISCRIBE=1
endif
TESTS_LOG_COMPILER = $(srcdir)/../../run-tests.py $(top_builddir)/util/hb-shape$(EXEEXT)