aboutsummaryrefslogtreecommitdiff
path: root/test/shape/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/shape/meson.build')
-rw-r--r--test/shape/meson.build29
1 files changed, 16 insertions, 13 deletions
diff --git a/test/shape/meson.build b/test/shape/meson.build
index dfc9f3297..beb6cd2c5 100644
--- a/test/shape/meson.build
+++ b/test/shape/meson.build
@@ -3,49 +3,52 @@ subdir('data/in-house') # in_house_tests
subdir('data/aots') # aots_tests
subdir('data/text-rendering-tests') # text_rendering_tests
-shaping_run_tests_py = find_program('run-tests.py')
+shape_run_tests_py = find_program('run-tests.py')
env = environment()
env.set('HAVE_FREETYPE', '@0@'.format(conf.get('HAVE_FREETYPE', 0)))
+env.set('HAVE_CORETEXT', '@0@'.format(conf.get('HAVE_CORETEXT', 0)))
+env.set('HAVE_DIRECTWRITE', '@0@'.format(conf.get('HAVE_DIRECTWRITE', 0)))
+env.set('HAVE_UNISCRIBE', '@0@'.format(conf.get('HAVE_UNISCRIBE', 0)))
foreach file_name : in_house_tests
test_name = file_name.split('.')[0]
- test(test_name, shaping_run_tests_py,
+ test(test_name, shape_run_tests_py,
args: [
hb_shape,
- join_paths(meson.current_source_dir(), 'data', 'in-house', 'tests', file_name),
+ meson.current_source_dir() / 'data' / 'in-house' / 'tests' / file_name,
],
env: env,
- workdir: join_paths(meson.current_build_dir(), '..', '..'),
- suite: ['shaping', 'in-house'],
+ workdir: meson.current_build_dir() / '..' / '..',
+ suite: ['shape', 'in-house'],
)
endforeach
foreach file_name : aots_tests
test_name = file_name.split('.')[0]
- test(test_name, shaping_run_tests_py,
+ test(test_name, shape_run_tests_py,
args: [
hb_shape,
- join_paths(meson.current_source_dir(), 'data', 'aots', 'tests', file_name),
+ meson.current_source_dir() / 'data' / 'aots' / 'tests' / file_name,
],
env: env,
- workdir: join_paths(meson.current_build_dir(), '..', '..'),
- suite: ['shaping', 'aots'],
+ workdir: meson.current_build_dir() / '..' / '..',
+ suite: ['shape', 'aots'],
)
endforeach
foreach file_name : text_rendering_tests
test_name = file_name.split('.')[0]
- test(test_name, shaping_run_tests_py,
+ test(test_name, shape_run_tests_py,
args: [
hb_shape,
- join_paths(meson.current_source_dir(), 'data', 'text-rendering-tests', 'tests', file_name),
+ meson.current_source_dir() / 'data' / 'text-rendering-tests' / 'tests' / file_name,
],
env: env,
- workdir: join_paths(meson.current_build_dir(), '..', '..'),
- suite: ['shaping', 'text-rendering-tests'],
+ workdir: meson.current_build_dir() / '..' / '..',
+ suite: ['shape', 'text-rendering-tests'],
)
endforeach