aboutsummaryrefslogtreecommitdiff
path: root/test/threads/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'test/threads/meson.build')
-rw-r--r--test/threads/meson.build28
1 files changed, 28 insertions, 0 deletions
diff --git a/test/threads/meson.build b/test/threads/meson.build
new file mode 100644
index 000000000..1848a1c6e
--- /dev/null
+++ b/test/threads/meson.build
@@ -0,0 +1,28 @@
+test('shape_threads', executable('hb-shape-threads', 'hb-shape-threads.cc',
+ dependencies: [
+ freetype_dep, thread_dep
+ ],
+ cpp_args: [],
+ include_directories: [incconfig, incsrc],
+ link_with: [libharfbuzz],
+ install: false,
+ ),
+ workdir: meson.current_source_dir() / '..' / '..',
+ timeout: 300,
+ suite: ['threads', 'slow'],
+)
+
+
+test('subset_threads', executable('hb-subset-threads', 'hb-subset-threads.cc',
+ dependencies: [
+ thread_dep
+ ],
+ cpp_args: [],
+ include_directories: [incconfig, incsrc],
+ link_with: [libharfbuzz, libharfbuzz_subset],
+ install: false,
+ ),
+ workdir: meson.current_source_dir() / '..' / '..',
+ timeout: 300,
+ suite: ['threads', 'slow'],
+)