aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTodd C. Miller <Todd.Miller@courtesan.com>2017-11-11 11:26:59 -0700
committerBruce A. Mah <bmah@kitchenlab.org>2017-11-11 10:26:59 -0800
commit480824e3c1c13d3ba9f918235491291b72fd25a1 (patch)
tree93c3cb2eb492a8fc2a5f83cfe2e00c623179b116 /configure.ac
parent73b02f98190e39c31c6479dbe9e6830392b3d18b (diff)
downloadiperf3-480824e3c1c13d3ba9f918235491291b72fd25a1.tar.gz
Remove a few unnecessary headers and unused functions. (#667)
* EXIT_SUCCESS and EXIT_FAILURE are defined in stdlib.h, not sysexits.h so no need to include the latter. * No need to include pthread.h. * Remove the no longer used delay() function. This also removes the reliance on nanosleep(). * Remove get_tcp_windowsize() and set_tcp_windowsize() which are unused. These days, iperf uses get/setsockopt() with SO_SNDBUF SO_RCVBUF directly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 0 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 2cb8c17..936ff39 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,12 +64,6 @@ echo "floor()"
exit 1
])
-# Solaris puts nanosleep in -lrt
-AC_SEARCH_LIBS(nanosleep, [rt], [], [
-echo "nanosleep() required for timing operations."
-exit 1
-])
-
# On illumos we need -lsocket
AC_SEARCH_LIBS(socket, [socket], [], [
echo "socket()"