aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBruce A. Mah <bmah@es.net>2016-05-26 09:47:48 -0700
committerBruce A. Mah <bmah@es.net>2016-05-26 09:47:48 -0700
commit9915746a8bf88050cd4cfee4295d063c1154e9a0 (patch)
tree74aad1026c7018e03634754becdb16b19bb54ef1 /configure.ac
parent0da552c390c8332a53b5a39cdfbe6ffccd749189 (diff)
downloadiperf3-9915746a8bf88050cd4cfee4295d063c1154e9a0.tar.gz
Squashed commit of the following:
commit 2dc03630a736be2ae9f64823aabb5776e7074c2a Merge: 61e325c 0da552c Author: Bruce A. Mah <bmah@es.net> Date: Thu May 26 09:40:58 2016 -0700 Merge branch 'master' into issue-325 commit 61e325c5d0a4e7a9823221ce507db0f478fc98b5 Merge: 227992f ccbcee6 Author: Bruce A. Mah <bmah@es.net> Date: Thu May 26 11:09:54 2016 -0400 Merge branch 'issue-325' of github.com:esnet/iperf into issue-325 Conflicts: src/iperf3.1 commit 227992f366e7f4895b6762011576ba22a42a752e Author: Bruce A. Mah <bmah@es.net> Date: Thu May 26 11:07:01 2016 -0400 Don't set SO_MAX_PACING_RATE if the rate is 0. Also tweak some help text. Towards #325, in response to feedback from @bltierney. commit ccbcee6366d50ec632fc00eb11fde8a886f8febe Author: Bruce A. Mah <bmah@es.net> Date: Tue May 24 09:19:41 2016 -0700 Fix manpage formatting for consistency. commit 90ac5a9ce09bd746ca5f943a8226ab864da3ebf8 Author: Bruce A. Mah <bmah@es.net> Date: Tue May 24 12:14:16 2016 -0400 Add some documentation for fair-queueing per-socket pacing. For #325. commit 5571059870f7aefefb574816de70b6406848888f Author: Bruce A. Mah <bmah@es.net> Date: Tue May 24 11:55:44 2016 -0400 Change the fair-queueing socket pacing logic in response to feedback. By default, on platforms where per-socket pacing is available, it will be used. If not available, iperf3 will fall back to application- level pacing. The --no-fq-socket-pacing option can be used to forcibly disable fair-queueing per-socket pacing. (The earlier --socket-pacing option has been removed.) Tested on CentOS 7, more testing on other platforms is required to be sure it didn't break the old application-level pacing behavior. For #325. commit 3e3f506fe9f375a5771c9e3ddfe8677c1a7146e7 Merge: 50a379e 3b23112 Author: Bruce A. Mah <bmah@es.net> Date: Tue May 24 09:54:39 2016 -0400 Merge branch 'master' into issue-325 commit 50a379eddfa89d1313d2aeeb62a6fbc82f00ea17 Author: Bruce A. Mah <bmah@es.net> Date: Sat Apr 16 02:55:42 2016 -0400 Regen. commit 200d3fe3917b3d298bdf52a0bde32c47cf2727b0 Author: Bruce A. Mah <bmah@es.net> Date: Sat Apr 16 02:41:32 2016 -0400 Checkpoint for initial work on #325 to add socket pacing. This works only on Linux and depends on the availability of the SO_MAX_PACING_RATE socket option and the fq queue discipline. Use --socket-pacing to use SO_MAX_PACING_RATE instead of the default iperf3 user-level rate limiting; in either case, the --bandwidth parameter controls the desired rate. Lightly tested with both --tcp and --udp, normal and --reverse. Real testing requires analysis of packet timestamps between multiple hosts.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 15 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e59a967..d3eb8f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# iperf, Copyright (c) 2014, 2015, The Regents of the University of
+# iperf, Copyright (c) 2014, 2015, 2016, The Regents of the University of
# California, through Lawrence Berkeley National Laboratory (subject
# to receipt of any required approvals from the U.S. Dept. of
# Energy). All rights reserved.
@@ -141,4 +141,18 @@ AC_CHECK_FUNCS([cpuset_setaffinity sched_setaffinity],
# it needs and what arguments it expects.
AC_CHECK_FUNCS([sendfile])
+# Check for packet pacing socket option (Linux only for now).
+AC_CACHE_CHECK([SO_MAX_PACING_RATE socket option],
+[iperf3_cv_header_so_max_pacing_rate],
+AC_EGREP_CPP(yes,
+[#include <sys/socket.h>
+#ifdef SO_MAX_PACING_RATE
+ yes
+#endif
+],iperf3_cv_header_so_max_pacing_rate=yes,iperf3_cv_header_so_max_pacing_rate=no))
+if test "x$iperf3_cv_header_so_max_pacing_rate" = "xyes"; then
+ AC_DEFINE([HAVE_SO_MAX_PACING_RATE], [1], [Have SO_MAX_PACING_RATE sockopt.])
+fi
+
+
AC_OUTPUT([Makefile src/Makefile src/version.h examples/Makefile iperf3.spec])