aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Evans <jasone@canonware.com>2016-11-02 08:54:07 -0700
committerJason Evans <jasone@canonware.com>2016-11-02 09:13:08 -0700
commit07ee4c5ff4c60e8e04eb452e2ef154c47fa118a4 (patch)
tree3e3ec4b480def314f6a047b0122ba7ef9007fe7a /configure.ac
parentf19bedb04cd3c2f603569ca9a40c8c66b05c3a90 (diff)
downloadjemalloc-07ee4c5ff4c60e8e04eb452e2ef154c47fa118a4.tar.gz
Force no lazy-lock on Windows.
Monitoring thread creation is unimplemented for Windows, which means lazy-lock cannot function correctly. This resolves #310.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 11 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 40681d1..4bdd66a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1434,9 +1434,17 @@ fi
],
[enable_lazy_lock=""]
)
-if test "x$enable_lazy_lock" = "x" -a "x${force_lazy_lock}" = "x1" ; then
- AC_MSG_RESULT([Forcing lazy-lock to avoid allocator/threading bootstrap issues])
- enable_lazy_lock="1"
+if test "x${enable_lazy_lock}" = "x" ; then
+ if test "x${force_lazy_lock}" = "x1" ; then
+ AC_MSG_RESULT([Forcing lazy-lock to avoid allocator/threading bootstrap issues])
+ enable_lazy_lock="1"
+ else
+ enable_lazy_lock="0"
+ fi
+fi
+if test "x${enable_lazy_lock}" = "x1" -a "x${abi}" = "xpecoff" ; then
+ AC_MSG_RESULT([Forcing no lazy-lock because thread creation monitoring is unimplemented])
+ enable_lazy_lock="0"
fi
if test "x$enable_lazy_lock" = "x1" ; then
if test "x$abi" != "xpecoff" ; then
@@ -1447,8 +1455,6 @@ if test "x$enable_lazy_lock" = "x1" ; then
])
fi
AC_DEFINE([JEMALLOC_LAZY_LOCK], [ ])
-else
- enable_lazy_lock="0"
fi
AC_SUBST([enable_lazy_lock])