aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJason Evans <jasone@canonware.com>2015-09-02 12:46:35 -0700
committerJason Evans <jasone@canonware.com>2015-09-02 12:46:35 -0700
commitc0f43b65500a78c87ef16579a33661103ec0a4fb (patch)
treebc2e94e08ad297cd1ddd0b4aa25a753c198be6fb /configure.ac
parent4a2a3c9a6e5f8fda3536f48095d68ddaa13cd977 (diff)
downloadjemalloc-c0f43b65500a78c87ef16579a33661103ec0a4fb.tar.gz
Fix TLS configuration.
Fix TLS configuration such that it is enabled by default for platforms on which it works correctly. This regression was introduced by ac5db02034c01357a4ce90504886046a58117921 (Make --enable-tls and --enable-lazy-lock take precedence over configure.ac-hardcoded defaults).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 14 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index f7c7f3c..5e77b68 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1272,13 +1272,16 @@ fi
,
enable_tls=""
)
-if test "x${enable_tls}" = "x" -a "x${force_tls}" = "x1" ; then
- AC_MSG_RESULT([Forcing TLS to avoid allocator/threading bootstrap issues])
- enable_tls="1"
-fi
-if test "x${enable_tls}" = "x" -a "x${force_tls}" = "x0" ; then
- AC_MSG_RESULT([Forcing no TLS to avoid allocator/threading bootstrap issues])
- enable_tls="0"
+if test "x${enable_tls}" = "x" ; then
+ if test "x${force_tls}" = "x1" ; then
+ AC_MSG_RESULT([Forcing TLS to avoid allocator/threading bootstrap issues])
+ enable_tls="1"
+ elif test "x${force_tls}" = "x0" ; then
+ AC_MSG_RESULT([Forcing no TLS to avoid allocator/threading bootstrap issues])
+ enable_tls="0"
+ else
+ enable_tls="1"
+ fi
fi
if test "x${enable_tls}" = "x1" ; then
AC_MSG_CHECKING([for TLS])
@@ -1298,9 +1301,12 @@ else
fi
AC_SUBST([enable_tls])
if test "x${enable_tls}" = "x1" ; then
+ if test "x${force_tls}" = "x0" ; then
+ AC_MSG_WARN([TLS enabled despite being marked unusable on this platform])
+ fi
AC_DEFINE_UNQUOTED([JEMALLOC_TLS], [ ])
elif test "x${force_tls}" = "x1" ; then
- AC_MSG_ERROR([Failed to configure TLS, which is mandatory for correct function])
+ AC_MSG_WARN([TLS disabled despite being marked critical on this platform])
fi
dnl ============================================================================