aboutsummaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
new file mode 100644
index 0000000..2a099c6
--- /dev/null
+++ b/tests/Makefile.am
@@ -0,0 +1,18 @@
+
+check_PROGRAMS = libconfig_tests
+noinst_PROGRAMS=$(check_PROGRAMS)
+TESTS = $(check_PROGRAMS)
+
+libconfig_tests_SOURCES = tests.c
+
+libconfig_tests_CPPFLAGS = -I$(top_srcdir)/tinytest -I$(top_srcdir)/lib
+
+libconfig_tests_LDADD = -L$(top_builddir)/tinytest -ltinytest \
+ -L$(top_builddir)/lib/.libs -lconfig
+
+
+EXTRA_DIST = \
+ tests.vcproj \
+ tests.vcxproj \
+ testdata/*.cfg \
+ testdata/*.txt