summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am59
1 files changed, 0 insertions, 59 deletions
diff --git a/Makefile.am b/Makefile.am
deleted file mode 100644
index ef13592..0000000
--- a/Makefile.am
+++ /dev/null
@@ -1,59 +0,0 @@
-# This file is part of libdaemon.
-#
-# Copyright 2003-2008 Lennart Poettering
-#
-# Permission is hereby granted, free of charge, to any person obtaining a copy
-# of this software and associated documentation files (the "Software"), to deal
-# in the Software without restriction, including without limitation the rights
-# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
-# copies of the Software, and to permit persons to whom the Software is
-# furnished to do so, subject to the following conditions:
-#
-# The above copyright notice and this permission notice shall be included in
-# all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
-# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
-# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
-# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
-# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
-# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
-# SOFTWARE.
-
-ACLOCAL_AMFLAGS = -I m4
-
-EXTRA_DIST=bootstrap.sh LICENSE
-SUBDIRS=libdaemon doc
-
-if EXAMPLES
-SUBDIRS += examples
-endif
-
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = pkgconfig/libdaemon.pc
-
-dist_noinst_DATA =
-MAINTAINERCLEANFILES=
-
-if USE_LYNX
-dist_noinst_DATA += README
-MAINTAINERCLEANFILES += README
-
-README:
- rm -f README
- $(MAKE) -C doc README
- ln -s doc/README README
-endif
-
-doxygen:
- $(MAKE) -C doc doxygen
-
-homepage: dist doxygen
- test -d $$HOME/homepage/private
- mkdir -p $$HOME/homepage/private/projects/libdaemon
- cp libdaemon-@PACKAGE_VERSION@.tar.gz $$HOME/homepage/private/projects/libdaemon
- cp doc/README.html doc/style.css $$HOME/homepage/private/projects/libdaemon
- ln -sf README.html $$HOME/homepage/private/projects/libdaemon/index.html
- cp -av doc/reference/ $$HOME/homepage/private/projects/libdaemon/
-
-.PHONY: homepage doxygen