aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorKonstantin Belousov <kostik@pooma.home>2010-04-05 16:14:50 +0300
committerKonstantin Belousov <kostik@pooma.home>2010-04-05 16:14:50 +0300
commitfd88f418184b82ea5dc191e16ae9f3705c865f68 (patch)
treeba617208389d5fe58310c10705d2b88b661b031b /src/Makefile.am
parent459b2a5ba89c3ae0002e741cadbc723e4b1dd0a6 (diff)
parent8e53e62db913470952b8eb541834b876f7a6882c (diff)
downloadlibunwind-fd88f418184b82ea5dc191e16ae9f3705c865f68.tar.gz
Merge remote branch 'origin/master' into freebsd
Conflicts: src/x86/Gis_signal_frame.c src/x86/Gstep.c src/x86_64/Gis_signal_frame.c src/x86_64/Gstep.c
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am26
1 files changed, 19 insertions, 7 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0aff658d..1c94e161 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -223,22 +223,24 @@ libunwind_la_SOURCES_x86_common = $(libunwind_la_SOURCES_common) \
# The list of files that go into libunwind:
libunwind_la_SOURCES_x86 = $(libunwind_la_SOURCES_x86_common) \
+ $(libunwind_la_SOURCES_x86_os_local) \
$(libunwind_la_SOURCES_local) \
$(dwarf_SOURCES_local) \
dwarf/Lfind_proc_info-lsb.c \
x86/Lcreate_addr_space.c x86/Lget_save_loc.c x86/Lglobal.c \
x86/Linit.c x86/Linit_local.c x86/Linit_remote.c \
- x86/Lis_signal_frame.c x86/Lget_proc_info.c x86/Lregs.c \
+ x86/Lget_proc_info.c x86/Lregs.c \
x86/Lresume.c x86/Lstep.c x86/getcontext.S
# The list of files that go into libunwind-x86:
libunwind_x86_la_SOURCES_x86 = $(libunwind_la_SOURCES_x86_common) \
+ $(libunwind_la_SOURCES_x86_os) \
$(libunwind_la_SOURCES_generic) \
$(dwarf_SOURCES_generic) \
dwarf/Gfind_proc_info-lsb.c \
x86/Gcreate_addr_space.c x86/Gget_save_loc.c x86/Gglobal.c \
x86/Ginit.c x86/Ginit_local.c x86/Ginit_remote.c \
- x86/Gis_signal_frame.c x86/Gget_proc_info.c x86/Gregs.c \
+ x86/Gget_proc_info.c x86/Gregs.c \
x86/Gresume.c x86/Gstep.c
# The list of files that go both into libunwind and libunwind-x86_64:
@@ -250,23 +252,25 @@ libunwind_la_SOURCES_x86_64_common = $(libunwind_la_SOURCES_common) \
# The list of files that go into libunwind:
libunwind_la_SOURCES_x86_64 = $(libunwind_la_SOURCES_x86_64_common) \
+ $(libunwind_la_SOURCES_x86_64_os_local) \
$(libunwind_la_SOURCES_local) \
$(dwarf_SOURCES_local) \
dwarf/Lfind_proc_info-lsb.c \
- x86_64/setcontext.S \
+ x86_64/setcontext.S \
x86_64/Lcreate_addr_space.c x86_64/Lget_save_loc.c x86_64/Lglobal.c \
x86_64/Linit.c x86_64/Linit_local.c x86_64/Linit_remote.c \
- x86_64/Lis_signal_frame.c x86_64/Lget_proc_info.c x86_64/Lregs.c \
+ x86_64/Lget_proc_info.c x86_64/Lregs.c \
x86_64/Lresume.c x86_64/Lstep.c x86_64/getcontext.S
# The list of files that go into libunwind-x86_64:
libunwind_x86_64_la_SOURCES_x86_64 = $(libunwind_la_SOURCES_x86_64_common) \
+ $(libunwind_la_SOURCES_x86_64_os) \
$(libunwind_la_SOURCES_generic) \
$(dwarf_SOURCES_generic) \
dwarf/Gfind_proc_info-lsb.c \
x86_64/Gcreate_addr_space.c x86_64/Gget_save_loc.c x86_64/Gglobal.c \
x86_64/Ginit.c x86_64/Ginit_local.c x86_64/Ginit_remote.c \
- x86_64/Gis_signal_frame.c x86_64/Gget_proc_info.c x86_64/Gregs.c \
+ x86_64/Gget_proc_info.c x86_64/Gregs.c \
x86_64/Gresume.c x86_64/Gstep.c
# The list of local files that go to Power 64 and 32:
@@ -344,8 +348,12 @@ install-exec-hook:
endif
if OS_LINUX
- libunwind_la_SOURCES_os = $(libunwind_la_SOURCES_os_linux)
- libunwind_la_SOURCES_os_local = $(libunwind_la_SOURCES_os_linux_local)
+ libunwind_la_SOURCES_os = $(libunwind_la_SOURCES_os_linux)
+ libunwind_la_SOURCES_os_local = $(libunwind_la_SOURCES_os_linux_local)
+ libunwind_la_SOURCES_x86_os = x86/Gos-linux.c
+ libunwind_la_SOURCES_x86_os_local = x86/Los-linux.c
+ libunwind_la_SOURCES_x86_64_os = x86_64/Gos-linux.c
+ libunwind_la_SOURCES_x86_64_os_local = x86_64/Los-linux.c
endif
if OS_HPUX
@@ -356,6 +364,10 @@ endif
if OS_FREEBSD
libunwind_la_SOURCES_os = $(libunwind_la_SOURCES_os_freebsd)
libunwind_la_SOURCES_os_local = $(libunwind_la_SOURCES_os_freebsd_local)
+ libunwind_la_SOURCES_x86_os = x86/Gos-freebsd.c
+ libunwind_la_SOURCES_x86_os_local = x86/Los-freebsd.c
+ libunwind_la_SOURCES_x86_64_os = x86_64/Gos-freebsd.c
+ libunwind_la_SOURCES_x86_64_os_local = x86_64/Los-freebsd.c
endif
if ARCH_ARM