aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorWind Yuan <feng.yuan@intel.com>2017-03-07 06:30:17 -0500
committerWind Yuan <feng.yuan@intel.com>2017-03-07 06:31:42 -0500
commit335069306b455db5f4dbde41b71e2ea089dc1abc (patch)
tree98c661360414684c2d9344391ad1498abae49baf /Makefile.am
parentd8262845e9c267a3da35598c2eec76a1ee39e6f4 (diff)
downloadlibxcam-335069306b455db5f4dbde41b71e2ea089dc1abc.tar.gz
build: mv pthread flags to confiugre
* export PTHREAD_LDFLAGS in configure.ac PTHREAD_LDFLAGS=" -pthread" Signed-off-by: Wind Yuan <feng.yuan@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 66f3f72..c7e33bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,5 +16,10 @@ TESTS_DIR =
endif
endif
+if ENABLE_CAPI
+CAPI_DIR = capi
+else
+CAPI_DIR =
+endif
SUBDIRS = xcore $(CLX_KERNEL_DIR) $(CLX_BIN_DIR) modules plugins \
- wrapper $(TESTS_DIR) pkgconfig
+ wrapper $(CAPI_DIR) $(TESTS_DIR) pkgconfig