aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2014-02-26 21:51:28 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2014-02-26 21:51:28 +0000
commit692c94c1c9b5642cecb8fc7b6fa5ce3145b70ff1 (patch)
treeb1cdb3e6a64575e2913fba1544816de705d9282a /CMakeLists.txt
parent685b0d9315c0e4305113e8a92b1891908c3f5fe6 (diff)
downloadllvm_35a-692c94c1c9b5642cecb8fc7b6fa5ce3145b70ff1.tar.gz
Use an install name dir of @executable_path/../lib instead of @rpath.
Using @executable_path/../lib matches what we have on Makefiles and works with older versions of OS X too. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@202302 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2ce214aabf..6c16afaeb5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -440,7 +440,7 @@ set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )
set(CMAKE_BUILD_WITH_INSTALL_RPATH ON)
if (APPLE)
- set(CMAKE_INSTALL_NAME_DIR "@rpath")
+ set(CMAKE_INSTALL_NAME_DIR "@executable_path/../lib")
set(CMAKE_INSTALL_RPATH "@executable_path/../lib")
else(UNIX)
if(NOT DEFINED CMAKE_INSTALL_RPATH)