aboutsummaryrefslogtreecommitdiff
path: root/contrib/meson/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'contrib/meson/meson.build')
-rw-r--r--contrib/meson/meson.build16
1 files changed, 11 insertions, 5 deletions
diff --git a/contrib/meson/meson.build b/contrib/meson/meson.build
index d1e97d9e..39672c8c 100644
--- a/contrib/meson/meson.build
+++ b/contrib/meson/meson.build
@@ -11,11 +11,17 @@
# The intention is that it can be easily moved to the root of the project
# (together with meson_options.txt) and packaged for wrapdb.
-project('lz4', ['c'],
- license: ['BSD', 'GPLv2'],
- default_options : ['c_std=c99',
- 'buildtype=release'],
+project(
+ 'lz4',
+ ['c'],
+ license: 'BSD-2-Clause-Patent AND GPL-2.0-or-later',
+ default_options: [
+ 'c_std=c99',
+ 'buildtype=release',
+ 'warning_level=3'
+ ],
version: 'DUMMY',
- meson_version: '>=0.47.0')
+ meson_version: '>=0.49.0'
+)
subdir('meson')