aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorQiang Yu <yuq825@gmail.com>2023-09-04 15:59:33 +0800
committerQiang Yu <yuq825@gmail.com>2023-10-26 10:27:55 +0800
commit0a564171f63eac6d81bbcb2aae72c788747c3c02 (patch)
treee49febff6d8d8704ec056cc025d37cb3e7a5631e /meson.build
parentbc59bbd43b916181e08084304ff2d695eda1784d (diff)
downloadmesa3d-0a564171f63eac6d81bbcb2aae72c788747c3c02.tar.gz
meson: be able to build radeonsi without llvm
Reviewed-by: Marek Olšák <marek.olsak@amd.com> Signed-off-by: Qiang Yu <yuq825@gmail.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/25632>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 722469fbe37..98974db2842 100644
--- a/meson.build
+++ b/meson.build
@@ -1755,8 +1755,8 @@ if with_llvm
endif
elif with_amd_vk and with_aco_tests
error('ACO tests require LLVM, but LLVM is disabled.')
-elif with_gallium_radeonsi or with_swrast_vk
- error('The following drivers require LLVM: RadeonSI, Lavapipe. One of these is enabled, but LLVM is disabled.')
+elif with_swrast_vk
+ error('The following drivers require LLVM: Lavapipe. One of these is enabled, but LLVM is disabled.')
elif with_gallium_opencl
error('The OpenCL "Clover" state tracker requires LLVM, but LLVM is disabled.')
elif with_clc