aboutsummaryrefslogtreecommitdiff
path: root/examples/cmake_relpath/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'examples/cmake_relpath/CMakeLists.txt')
-rw-r--r--examples/cmake_relpath/CMakeLists.txt18
1 files changed, 0 insertions, 18 deletions
diff --git a/examples/cmake_relpath/CMakeLists.txt b/examples/cmake_relpath/CMakeLists.txt
deleted file mode 100644
index e7727d8..0000000
--- a/examples/cmake_relpath/CMakeLists.txt
+++ /dev/null
@@ -1,18 +0,0 @@
-cmake_minimum_required(VERSION 2.8)
-project(NANOPB_CMAKE_SIMPLE C)
-
-set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/../../extra)
-find_package(Nanopb REQUIRED)
-include_directories(${NANOPB_INCLUDE_DIRS})
-
-nanopb_generate_cpp(PROTO_SRCS PROTO_HDRS RELPATH proto
- proto/simple.proto proto/sub/unlucky.proto)
-
-include_directories(${CMAKE_CURRENT_BINARY_DIR})
-#add_custom_target(generate_proto_sources DEPENDS ${PROTO_SRCS} ${PROTO_HDRS})
-set_source_files_properties(${PROTO_SRCS} ${PROTO_HDRS}
- PROPERTIES GENERATED TRUE)
-
-set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -Werror -g -O0")
-
-add_executable(simple simple.c ${PROTO_SRCS} ${PROTO_HDRS})