aboutsummaryrefslogtreecommitdiff
path: root/src/extensions/compact/Makefile.am
diff options
context:
space:
mode:
authorIan Hodson <idh@google.com>2012-05-30 21:27:06 +0100
committerIan Hodson <idh@google.com>2012-05-30 22:47:36 +0100
commitf4c12fce1ee58e670f9c3fce46c40296ba9ee8a2 (patch)
treeb131ed907f9b2d5af09c0983b651e9e69bc6aab9 /src/extensions/compact/Makefile.am
parenta92766f0a6ba4fac46cd6fd3856ef20c3b204f0d (diff)
downloadopenfst-jb-mr1-dev.tar.gz
Moved from GoogleTTS Change-Id: I6bc6bdadaa53bd0f810b88443339f6d899502cc8
Diffstat (limited to 'src/extensions/compact/Makefile.am')
-rw-r--r--src/extensions/compact/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/extensions/compact/Makefile.am b/src/extensions/compact/Makefile.am
new file mode 100644
index 0000000..b80cd3e
--- /dev/null
+++ b/src/extensions/compact/Makefile.am
@@ -0,0 +1,52 @@
+AM_CPPFLAGS = -I$(srcdir)/../../include $(ICU_CPPFLAGS)
+
+libfstdir = @libfstdir@
+libfst_LTLIBRARIES = libfstcompact.la compact8_acceptor-fst.la compact8_string-fst.la compact8_unweighted-fst.la compact8_unweighted_acceptor-fst.la compact8_weighted_string-fst.la compact16_acceptor-fst.la compact16_string-fst.la compact16_unweighted-fst.la compact16_unweighted_acceptor-fst.la compact16_weighted_string-fst.la compact64_acceptor-fst.la compact64_string-fst.la compact64_unweighted-fst.la compact64_unweighted_acceptor-fst.la compact64_weighted_string-fst.la
+
+libfstcompact_la_SOURCES = compact8_acceptor-fst.cc compact8_string-fst.cc compact8_unweighted-fst.cc compact8_unweighted_acceptor-fst.cc compact8_weighted_string-fst.cc compact16_acceptor-fst.cc compact16_string-fst.cc compact16_unweighted-fst.cc compact16_unweighted_acceptor-fst.cc compact16_weighted_string-fst.cc compact64_acceptor-fst.cc compact64_string-fst.cc compact64_unweighted-fst.cc compact64_unweighted_acceptor-fst.cc compact64_weighted_string-fst.cc
+libfstcompact_la_LDFLAGS = -version-info 0:0:0
+
+compact8_acceptor_fst_la_SOURCES = compact8_acceptor-fst.cc
+compact8_acceptor_fst_la_LDFLAGS = -module
+
+compact8_string_fst_la_SOURCES = compact8_string-fst.cc
+compact8_string_fst_la_LDFLAGS = -module
+
+compact8_unweighted_fst_la_SOURCES = compact8_unweighted-fst.cc
+compact8_unweighted_fst_la_LDFLAGS = -module
+
+compact8_unweighted_acceptor_fst_la_SOURCES = compact8_unweighted_acceptor-fst.cc
+compact8_unweighted_acceptor_fst_la_LDFLAGS = -module
+
+compact8_weighted_string_fst_la_SOURCES = compact8_weighted_string-fst.cc
+compact8_weighted_string_fst_la_LDFLAGS = -module
+
+compact16_acceptor_fst_la_SOURCES = compact16_acceptor-fst.cc
+compact16_acceptor_fst_la_LDFLAGS = -module
+
+compact16_string_fst_la_SOURCES = compact16_string-fst.cc
+compact16_string_fst_la_LDFLAGS = -module
+
+compact16_unweighted_fst_la_SOURCES = compact16_unweighted-fst.cc
+compact16_unweighted_fst_la_LDFLAGS = -module
+
+compact16_unweighted_acceptor_fst_la_SOURCES = compact16_unweighted_acceptor-fst.cc
+compact16_unweighted_acceptor_fst_la_LDFLAGS = -module
+
+compact16_weighted_string_fst_la_SOURCES = compact16_weighted_string-fst.cc
+compact16_weighted_string_fst_la_LDFLAGS = -module
+
+compact64_acceptor_fst_la_SOURCES = compact64_acceptor-fst.cc
+compact64_acceptor_fst_la_LDFLAGS = -module
+
+compact64_string_fst_la_SOURCES = compact64_string-fst.cc
+compact64_string_fst_la_LDFLAGS = -module
+
+compact64_unweighted_fst_la_SOURCES = compact64_unweighted-fst.cc
+compact64_unweighted_fst_la_LDFLAGS = -module
+
+compact64_unweighted_acceptor_fst_la_SOURCES = compact64_unweighted_acceptor-fst.cc
+compact64_unweighted_acceptor_fst_la_LDFLAGS = -module
+
+compact64_weighted_string_fst_la_SOURCES = compact64_weighted_string-fst.cc
+compact64_weighted_string_fst_la_LDFLAGS = -module