aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWyatt Hepler <hepler@google.com>2022-08-04 22:49:04 +0000
committerCQ Bot Account <pigweed-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-08-04 22:49:04 +0000
commit13018162ab7b4e10b0e59e3a0736cf0759186db2 (patch)
treeeb4168030dc407000aef67bfc02fee01ad0f421d /CMakeLists.txt
parent492d25bf00499344c759f2f2aff33bfa380a9cf1 (diff)
downloadpigweed-13018162ab7b4e10b0e59e3a0736cf0759186db2.tar.gz
pw_compilation_testing: Negative compilation testing
Support for defining tests that verify that compilation fails when it should fail. Fixes: b/234882063 Change-Id: If2dbf14a7bae63cc286bcc72a3dcc16c089eb891 Reviewed-on: https://pigweed-review.googlesource.com/c/pigweed/pigweed/+/42240 Reviewed-by: Keir Mierle <keir@google.com> Pigweed-Auto-Submit: Wyatt Hepler <hepler@google.com> Commit-Queue: Wyatt Hepler <hepler@google.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 048882bf0..5f27641a6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -46,6 +46,7 @@ add_subdirectory(pw_chrono EXCLUDE_FROM_ALL)
add_subdirectory(pw_chrono_freertos EXCLUDE_FROM_ALL)
add_subdirectory(pw_chrono_stl EXCLUDE_FROM_ALL)
add_subdirectory(pw_chrono_zephyr EXCLUDE_FROM_ALL)
+add_subdirectory(pw_compilation_testing EXCLUDE_FROM_ALL)
add_subdirectory(pw_containers EXCLUDE_FROM_ALL)
add_subdirectory(pw_cpu_exception EXCLUDE_FROM_ALL)
add_subdirectory(pw_cpu_exception_cortex_m EXCLUDE_FROM_ALL)