aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorYuval Peress <peress@google.com>2022-09-01 05:20:35 +0000
committerCQ Bot Account <pigweed-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-09-01 05:20:35 +0000
commit65c3d9bd709165572d2d94a85c0b6f5e9262f55a (patch)
tree2057e60e3be8bf52e1ed94fee301420210e99892 /CMakeLists.txt
parent7681b28af948a7d18c948295c931e8e6d8f978eb (diff)
downloadpigweed-65c3d9bd709165572d2d94a85c0b6f5e9262f55a.tar.gz
zephyr: Fixup ToT to support Zephyr builds
Add the zephyr/ prefix to the include paths needed for ToT zephyr builds as well as removing the type-limits warning. Type limit warnings don't work with Zephyr because of the Kconfig feature. In a given build we can check `uintptr >= CONFIG_X` and CONFIG_X may be 0, but in another build it might be 10. Bug: b/236263182 Change-Id: Iaf3a5075a4af51f740efe66abcd709d6d9796396 Signed-off-by: Yuval Peress <peress@google.com> Reviewed-on: https://pigweed-review.googlesource.com/c/pigweed/pigweed/+/108834 Reviewed-by: Wyatt Hepler <hepler@google.com> Reviewed-by: Rob Barnes <robbarnes@google.com> Commit-Queue: Auto-Submit <auto-submit@pigweed.google.com.iam.gserviceaccount.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5f27641a6..d4cf398b5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,10 @@ if(CONFIG_ZEPHYR_PIGWEED_MODULE)
pw_set_zephyr_backend_ifdef(CONFIG_PIGWEED_SYNC_MUTEX pw_sync.mutex pw_sync_zephyr.mutex_backend)
pw_set_zephyr_backend_ifdef(CONFIG_PIGWEED_SYNC_BINARY_SEMAPHORE pw_sync.mutex pw_sync_zephyr.binary_semaphore_backend)
pw_set_zephyr_backend_ifdef(CONFIG_PIGWEED_SYS_IO pw_sys_io pw_sys_io_zephyr)
+
+ if(CONFIG_NANOPB AND "${dir_pw_third_party_nanopb}" STREQUAL "")
+ set(dir_pw_third_party_nanopb "${ZEPHYR_NANOPB_MODULE_DIR}" CACHE PATH "" FORCE)
+ endif()
endif()
add_subdirectory(pw_assert EXCLUDE_FROM_ALL)