aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorBrian Barcenas <bbarcenas@google.com>2022-10-20 21:24:39 +0000
committerCQ Bot Account <pigweed-scoped@luci-project-accounts.iam.gserviceaccount.com>2022-10-20 21:24:39 +0000
commitfbd6d5d792e598dbfcb8c1ac5df100c5e9f0aa12 (patch)
tree1fc32f62b01d264272d40e9be99dcd618e27706f /CMakeLists.txt
parente2a224838d33ce76aa174a54faeb786492f174ad (diff)
downloadpigweed-fbd6d5d792e598dbfcb8c1ac5df100c5e9f0aa12.tar.gz
pw_perf_test: Added internal timing facade + backend
pw_perf_test now has a backend for which it will use to time the tested components. This update includes an implementation with pw_chrono, which will be used for time-based measurements(nanoseconds). Change-Id: I9a1bb9cf0964caa4d911a1c7c016bab3a41f1e32 Reviewed-on: https://pigweed-review.googlesource.com/c/pigweed/pigweed/+/113890 Reviewed-by: Wyatt Hepler <hepler@google.com> Commit-Queue: Brian Barcenas <bbarcenas@google.com> Reviewed-by: Erik Gilling <konkers@google.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d29514a80..3e14f246a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -72,6 +72,7 @@ add_subdirectory(pw_minimal_cpp_stdlib EXCLUDE_FROM_ALL)
add_subdirectory(pw_metric EXCLUDE_FROM_ALL)
add_subdirectory(pw_multisink EXCLUDE_FROM_ALL)
add_subdirectory(pw_persistent_ram EXCLUDE_FROM_ALL)
+add_subdirectory(pw_perf_test EXCLUDE_FROM_ALL)
add_subdirectory(pw_polyfill EXCLUDE_FROM_ALL)
add_subdirectory(pw_preprocessor EXCLUDE_FROM_ALL)
add_subdirectory(pw_protobuf EXCLUDE_FROM_ALL)