aboutsummaryrefslogtreecommitdiff
path: root/pw_build/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'pw_build/CMakeLists.txt')
-rw-r--r--pw_build/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/pw_build/CMakeLists.txt b/pw_build/CMakeLists.txt
index b2eeef016..602dd4a66 100644
--- a/pw_build/CMakeLists.txt
+++ b/pw_build/CMakeLists.txt
@@ -71,6 +71,7 @@ target_compile_options(pw_build.extra_strict_warnings
INTERFACE
"-Wshadow"
"-Wredundant-decls"
+ $<$<COMPILE_LANGUAGE:C>:-Wstrict-prototypes>
)
add_library(pw_build.cpp17 INTERFACE)