aboutsummaryrefslogtreecommitdiff
path: root/targets/host/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'targets/host/CMakeLists.txt')
-rw-r--r--targets/host/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/targets/host/CMakeLists.txt b/targets/host/CMakeLists.txt
new file mode 100644
index 000000000..dfacc2505
--- /dev/null
+++ b/targets/host/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright 2020 The Pigweed Authors
+#
+# Licensed under the Apache License, Version 2.0 (the "License"); you may not
+# use this file except in compliance with the License. You may obtain a copy of
+# the License at
+#
+# https://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
+# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
+# License for the specific language governing permissions and limitations under
+# the License.
+
+include("$ENV{PW_ROOT}/pw_build/pigweed.cmake")
+
+pw_add_module_library(targets.host.system_rpc_server
+ IMPLEMENTS_FACADES
+ pw_rpc.system_server
+ SOURCES
+ system_rpc_server.cc
+ PRIVATE_DEPS
+ pw_hdlc
+ pw_rpc.server
+ pw_rpc.synchronized_channel_output
+ pw_stream.socket_stream
+)