aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristopher Wilcox <crwilcox@google.com>2020-06-11 16:05:28 -0700
committerGitHub <noreply@github.com>2020-06-11 16:05:28 -0700
commit9434868a6789464549af1d4562f62d8a899b6809 (patch)
tree844d15f2ce57e4b344e0bfeac0c71cb020e0a3bc /setup.py
parent67d38d814c2177b0fd3a51485b0fe727076c0b15 (diff)
downloadgoogle-auth-library-python-9434868a6789464549af1d4562f62d8a899b6809.tar.gz
fix: narrow acceptable RSA versions to maintain Python 2 compatability (#528)
* Narrow acceptable RSA versions to maintain Python 2 compat * Update setup.py Co-authored-by: Kamil Breguła <mik-laj@users.noreply.github.com> * Use a more specific pin to support new versions that may support python 2. * Update setup.py Co-authored-by: Bu Sun Kim <8822365+busunkim96@users.noreply.github.com> * how many commits to get the format correct? Co-authored-by: Kamil Breguła <mik-laj@users.noreply.github.com> Co-authored-by: Bu Sun Kim <8822365+busunkim96@users.noreply.github.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f518ec1..0762da8 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,9 @@ from setuptools import setup
DEPENDENCIES = (
"cachetools>=2.0.0,<5.0",
"pyasn1-modules>=0.2.1",
- "rsa>=3.1.4,<5.0",
+ # rsa 4.1, 4.1.1, 4.2 are broken on Py2: https://github.com/sybrenstuvel/python-rsa/issues/152
+ 'rsa>=3.1.4,!=4.1,!=4.1.1,!=4.2,<5; python_version < "3"',
+ 'rsa>=3.1.4,<5; python_version >= "3"',
"setuptools>=40.3.0",
"six>=1.9.0",
)