aboutsummaryrefslogtreecommitdiff
path: root/tests/test_cmake_build/installed_embed/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/test_cmake_build/installed_embed/CMakeLists.txt')
-rw-r--r--tests/test_cmake_build/installed_embed/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/tests/test_cmake_build/installed_embed/CMakeLists.txt b/tests/test_cmake_build/installed_embed/CMakeLists.txt
index 64ae5c4b..d9dcb45e 100644
--- a/tests/test_cmake_build/installed_embed/CMakeLists.txt
+++ b/tests/test_cmake_build/installed_embed/CMakeLists.txt
@@ -1,12 +1,12 @@
-cmake_minimum_required(VERSION 3.4)
+cmake_minimum_required(VERSION 3.5)
-# The `cmake_minimum_required(VERSION 3.4...3.18)` syntax does not work with
+# The `cmake_minimum_required(VERSION 3.5...3.26)` syntax does not work with
# some versions of VS that have a patched CMake 3.11. This forces us to emulate
# the behavior using the following workaround:
-if(${CMAKE_VERSION} VERSION_LESS 3.18)
+if(${CMAKE_VERSION} VERSION_LESS 3.26)
cmake_policy(VERSION ${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION})
else()
- cmake_policy(VERSION 3.18)
+ cmake_policy(VERSION 3.26)
endif()
project(test_installed_embed CXX)
@@ -22,5 +22,7 @@ set_target_properties(test_installed_embed PROPERTIES OUTPUT_NAME test_cmake_bui
# This may be needed to resolve header conflicts, e.g. between Python release and debug headers.
set_target_properties(test_installed_embed PROPERTIES NO_SYSTEM_FROM_IMPORTED ON)
-add_custom_target(check_installed_embed $<TARGET_FILE:test_installed_embed>
- ${PROJECT_SOURCE_DIR}/../test.py)
+add_custom_target(
+ check_installed_embed
+ $<TARGET_FILE:test_installed_embed> ${PROJECT_SOURCE_DIR}/../test.py
+ DEPENDS test_installed_embed)