aboutsummaryrefslogtreecommitdiff
path: root/tests/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'tests/setup.py')
-rwxr-xr-xtests/setup.py26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/setup.py b/tests/setup.py
new file mode 100755
index 0000000..f874cbe
--- /dev/null
+++ b/tests/setup.py
@@ -0,0 +1,26 @@
+#!/usr/bin/python
+#
+# Copyright 2014 Google Inc. All rights reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+
+from distutils.core import setup, Extension
+
+module = Extension('_fastrand',
+ sources = ['_fastrand.c'])
+
+setup(name = '_fastrand',
+ version = '1.0',
+ description = 'Module to speed up RAPPOR simulation',
+ ext_modules = [module])