aboutsummaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml24
1 files changed, 15 insertions, 9 deletions
diff --git a/Cargo.toml b/Cargo.toml
index a2d9ba7..86aaf75 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,32 +3,38 @@
# When uploading crates to the registry Cargo will automatically
# "normalize" Cargo.toml files for maximal compatibility
# with all versions of Cargo and also rewrite `path` dependencies
-# to registry (e.g., crates.io) dependencies
+# to registry (e.g., crates.io) dependencies.
#
-# If you believe there's an error in this file please file an
-# issue against the rust-lang/cargo repository. If you're
-# editing this file be aware that the upstream Cargo.toml
-# will likely look very different (and much more reasonable)
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
[package]
edition = "2018"
+rust-version = "1.45"
name = "async-stream"
-version = "0.3.2"
+version = "0.3.4"
authors = ["Carl Lerche <me@carllerche.com>"]
description = "Asynchronous streams using async & await notation"
-homepage = "https://github.com/tokio-rs/async-stream"
-documentation = "https://docs.rs/async-stream"
readme = "README.md"
license = "MIT"
repository = "https://github.com/tokio-rs/async-stream"
+
[dependencies.async-stream-impl]
-version = "=0.3.2"
+version = "=0.3.4"
[dependencies.futures-core]
version = "0.3"
+
+[dependencies.pin-project-lite]
+version = "0.2"
+
[dev-dependencies.futures-util]
version = "0.3"
+[dev-dependencies.rustversion]
+version = "1"
+
[dev-dependencies.tokio]
version = "1"
features = ["full"]